{"answers":{"affected":"3 open source packages ship an affected version, including simiki. It affects 1 product.","exploited":"There is no known exploitation of CVE-2020-19001 in the wild and no public exploit code.","fix":"Upgrade simiki to 1.6.2.2 or later.","what":"CVE-2020-19001 is a critical command injection vulnerability in n/a, published on 27 Aug 2021. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2020-19001 and fix it if it is affected.\n\nWhat it is: CVE-2020-19001 is a critical command injection vulnerability in n/a, published on 27 Aug 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2020-19001 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- simiki (PyPI): affected all versions; fixed in 1.6.2.2\n- simiki (PyPI): affected all versions; fixed in 1.6.2.2\n- simiki (PyPI): affected all versions; fixed in 1.6.2.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-19001/ (Markdown: https://insights.sbomify.com/CVE-2020-19001/index.md)","id":"CVE-2020-19001","markdown":"https://insights.sbomify.com/CVE-2020-19001/index.md","name":"CVE-2020-19001","record":{"aliases":["GHSA-w873-xcqq-x922","PYSEC-2021-348"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Python static site generator","requires_auth":"none","summary":"Remote attackers can execute arbitrary system commands in Simiki due to improper input handling in the configuration module.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"simiki","vendor":"simiki_project"}],"cvss":{"score":9.8,"severity":"critical","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-77","name":"Improper Neutralization of Special Elements used in a Command"}],"description":"Command Injection in Simiki v1.6.2.1 and prior allows remote attackers to execute arbitrary system commands via line 64 of the component 'simiki/blob/master/simiki/config.py'.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Command Injection in Simiki","id":"CVE-2020-19001","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"command_injection","year":"2020"},"n_packages":3,"n_references":2,"next":{"headline":"Mezzanine Cross Site Scripting (XSS) vulnerability","id":"CVE-2020-19002"},"packages":[{"ecosystem":"PyPI","fixed":["1.6.2.2"],"introduced":["0"],"last_affected":[],"package":"simiki","purl":null,"source":"GHSA-w873-xcqq-x922"},{"ecosystem":"PyPI","fixed":["1.6.2.2"],"introduced":["0"],"last_affected":[],"package":"simiki","purl":"pkg:pypi/simiki","source":"GHSA-w873-xcqq-x922"},{"ecosystem":"PyPI","fixed":["1.6.2.2"],"introduced":["0"],"last_affected":[],"package":"simiki","purl":"pkg:pypi/simiki","source":"PYSEC-2021-348"}],"prev":{"headline":"Cross Site Scripting (XSS) in Simiki","id":"CVE-2020-19000"},"products":["n/a"],"published":"2021-08-27","related":[{"cvss_score":6.1,"headline":"Cross Site Scripting (XSS) in Simiki","id":"CVE-2020-19000","kev_date_added":null,"published":"2021-08-27"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["n/a"]},"summary":"Remote attackers can execute arbitrary system commands in Simiki due to improper input handling in the configuration module.","url":"https://insights.sbomify.com/CVE-2020-19001/"}