# CVE-2020-19001: Command Injection in Simiki

> Remote attackers can execute arbitrary system commands in Simiki due to improper input handling in the configuration module.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Aug 2021
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-w873-xcqq-x922, PYSEC-2021-348

## What is CVE-2020-19001?

CVE-2020-19001 is a critical command injection vulnerability in n/a, published on 27 Aug 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Command Injection in Simiki v1.6.2.1 and prior allows remote attackers to execute arbitrary system commands via line 64 of the component 'simiki/blob/master/simiki/config.py'.

Weakness: CWE-77 (Improper Neutralization of Special Elements used in a Command)

## Which versions are affected by CVE-2020-19001?

3 open source packages ship an affected version, including simiki. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `simiki` | PyPI | All versions | 1.6.2.2 |
| `simiki` | PyPI | All versions | 1.6.2.2 |
| `simiki` | PyPI | All versions | 1.6.2.2 |

Products: Simiki Project Simiki.

## How do I fix CVE-2020-19001?

Upgrade simiki to 1.6.2.2 or later.

## Is CVE-2020-19001 being exploited?

There is no known exploitation of CVE-2020-19001 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2020-19000](https://insights.sbomify.com/CVE-2020-19000/): Cross Site Scripting (XSS) in Simiki (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-19001 and fix it if it is affected.

What it is: CVE-2020-19001 is a critical command injection vulnerability in n/a, published on 27 Aug 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-19001 in the wild and no public exploit code.

Affected packages and fixed versions:
- simiki (PyPI): affected all versions; fixed in 1.6.2.2
- simiki (PyPI): affected all versions; fixed in 1.6.2.2
- simiki (PyPI): affected all versions; fixed in 1.6.2.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-19001/ (Markdown: https://insights.sbomify.com/CVE-2020-19001/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-19001
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-19001
- OSV: https://osv.dev/vulnerability/CVE-2020-19001

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-19001/
Summaries are generated and may contain mistakes; the official description above is the record.
