# CVE-2020-1927: Open redirect in Apache HTTP Server

> Attackers can exploit encoded newlines in mod_rewrite rules to redirect users to unexpected URLs, bypassing intended self-referential redirects.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 1 Apr 2020
- **Updated:** 4 Aug 2024
- **Also known as:** ALPINE-CVE-2020-1927, BIT-apache-2020-1927, CLEANSTART-2026-VO42453, DEBIAN-CVE-2020-1927, GHSA-h8gj-rgqf-fpq3, UBUNTU-CVE-2020-1927

## What is CVE-2020-1927?

CVE-2020-1927 is a medium-severity vulnerability in Apache Http Server, published on 1 Apr 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

In Apache HTTP Server 2.4.0 to 2.4.41, redirects configured with mod_rewrite that were intended to be self-referential might be fooled by encoded newlines and redirect instead to an an unexpected URL within the request URL.

Weakness: CWE-601 (URL Redirection to Untrusted Site)

## Which versions are affected by CVE-2020-1927?

1 open source package ship an affected version, including apache. It affects 14 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache` | Bitnami | From 2.4.0 | 2.4.42 |

Products: Apache Http Server, Broadcom Brocade Fabric Operating System, Canonical Ubuntu Linux, Debian Debian Linux, Fedoraproject Fedora, Netapp Oncommand Unified Manager Core Package, Opensuse Leap, Oracle Communications Element Manager, Oracle Communications Session Report Manager, Oracle Communications Session Route Manager, Oracle Enterprise Manager Ops Center, Oracle Instantis Enterprisetrack, Oracle Sd-Wan Aware, Oracle Zfs Storage Appliance Kit.

## How do I fix CVE-2020-1927?

Upgrade apache to 2.4.42 or later.

## Is CVE-2020-1927 being exploited?

There is no known exploitation of CVE-2020-1927 in the wild and no public exploit code.

## Other vulnerabilities in Apache Http Server

- [CVE-2021-42013](https://insights.sbomify.com/CVE-2021-42013/): Apache HTTP Server Path Traversal (critical 9.8, exploited in the wild)
- [CVE-2024-38475](https://insights.sbomify.com/CVE-2024-38475/): Apache HTTP Server Improper Escaping of Output (critical 9.1, exploited in the wild)
- [CVE-2021-40438](https://insights.sbomify.com/CVE-2021-40438/): Apache HTTP Server-Side Request Forgery (SSRF) (critical 9.0, exploited in the wild)
- [CVE-2019-0211](https://insights.sbomify.com/CVE-2019-0211/): Apache HTTP Server Privilege Escalation (high 7.8, exploited in the wild)
- [CVE-2021-41773](https://insights.sbomify.com/CVE-2021-41773/): Apache HTTP Server Path Traversal (high 7.5, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-1927 and fix it if it is affected.

What it is: CVE-2020-1927 is a medium-severity vulnerability in Apache Http Server, published on 1 Apr 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2020-1927 in the wild and no public exploit code.

Affected packages and fixed versions:
- apache (Bitnami): affected from 2.4.0; fixed in 2.4.42

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-1927/ (Markdown: https://insights.sbomify.com/CVE-2020-1927/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-1927
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-1927
- OSV: https://osv.dev/vulnerability/CVE-2020-1927

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-1927/
Summaries are generated and may contain mistakes; the official description above is the record.
