# CVE-2020-1928: Apache NiFi Insertion of Sensitive Information into Log File

> Apache NiFi logs sensitive parameter values, allowing attackers with log access to read confidential data.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Jan 2020
- **Updated:** 4 Aug 2024
- **Also known as:** BIT-nifi-2020-1928, GHSA-w4fj-ccr6-7pcp

## What is CVE-2020-1928?

CVE-2020-1928 is a medium-severity vulnerability in Apache Nifi, published on 28 Jan 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An information disclosure vulnerability was found in Apache NiFi 1.10.0. The sensitive parameter parser would log parsed values for debugging purposes. This would expose literal values entered in a sensitive property when no parameter was present.

Weakness: CWE-532 (Insertion of Sensitive Information into Log File)

## Which versions are affected by CVE-2020-1928?

3 open source packages ship an affected version, including org.apache.nifi:nifi-parameter and nifi. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.nifi:nifi-parameter` | Maven | From 1.10.0 | 1.11.0 |
| `org.apache.nifi:nifi-parameter` | Maven | From 1.10.0 | 1.11.0 |
| `nifi` | Bitnami | From 1.10.0 to 1.10.0 | None |

Products: Apache Nifi.

## How do I fix CVE-2020-1928?

Upgrade org.apache.nifi:nifi-parameter to 1.11.0 or later.

## Is CVE-2020-1928 being exploited?

There is no known exploitation of CVE-2020-1928 in the wild and no public exploit code.

## Other vulnerabilities in Apache Nifi

- [CVE-2018-1309](https://insights.sbomify.com/CVE-2018-1309/): Improper Restriction of XML External Entity Reference in Apache NiFi (critical 9.8)
- [CVE-2017-15697](https://insights.sbomify.com/CVE-2017-15697/): Apache NiFi XSS issue in context path handling (critical 9.8)
- [CVE-2017-5636](https://insights.sbomify.com/CVE-2017-5636/): Injection in Apache NiFi (critical 9.8)
- [CVE-2026-68981](https://insights.sbomify.com/CVE-2026-68981/): Apache NiFi: Uncontrolled Resource Consumption through Decompression of HTTP Requests (high 8.8)
- [CVE-2023-36542](https://insights.sbomify.com/CVE-2023-36542/): Apache NiFi: Potential Code Injection with Properties Referencing Remote Resources (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-1928 and fix it if it is affected.

What it is: CVE-2020-1928 is a medium-severity vulnerability in Apache Nifi, published on 28 Jan 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-1928 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.nifi:nifi-parameter (Maven): affected from 1.10.0; fixed in 1.11.0
- org.apache.nifi:nifi-parameter (Maven): affected from 1.10.0; fixed in 1.11.0
- nifi (Bitnami): affected from 1.10.0 up to 1.10.0; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-1928/ (Markdown: https://insights.sbomify.com/CVE-2020-1928/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-1928
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-1928
- OSV: https://osv.dev/vulnerability/CVE-2020-1928

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-1928/
Summaries are generated and may contain mistakes; the official description above is the record.
