# CVE-2020-1929: Improper Certificate Validation in Apache Beam

> The Apache Beam MongoDB connector incorrectly disables SSL certificate verification globally, allowing man-in-the-middle attacks against any JVM application using the library.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Jan 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-2m7g-9q74-9m3q

## What is CVE-2020-1929?

CVE-2020-1929 is a high-severity vulnerability in Apache Beam, published on 15 Jan 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The Apache Beam MongoDB connector in versions 2.10.0 to 2.16.0 has an option to disable SSL trust verification. However this configuration is not respected and the certificate verification disables trust verification in every case. This exclusion also gets registered globally which disables trust checking for any code running in the same JVM.

Weakness: CWE-295 (Improper Certificate Validation)

## Which versions are affected by CVE-2020-1929?

2 open source packages ship an affected version, including org.apache.beam:beam-sdks-java-io-mongodb. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.beam:beam-sdks-java-io-mongodb` | Maven | From 2.10.0 | 2.17.0 |
| `org.apache.beam:beam-sdks-java-io-mongodb` | Maven | From 2.10.0 | 2.17.0 |

Products: Apache Beam.

## How do I fix CVE-2020-1929?

Upgrade org.apache.beam:beam-sdks-java-io-mongodb to 2.17.0 or later.

## Is CVE-2020-1929 being exploited?

There is no known exploitation of CVE-2020-1929 in the wild and no public exploit code.

## Other vulnerabilities in Apache Beam

- [CVE-2020-27216](https://insights.sbomify.com/CVE-2020-27216/): Local Temp Directory Hijacking Vulnerability (high 7.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-1929 and fix it if it is affected.

What it is: CVE-2020-1929 is a high-severity vulnerability in Apache Beam, published on 15 Jan 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-1929 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.beam:beam-sdks-java-io-mongodb (Maven): affected from 2.10.0; fixed in 2.17.0
- org.apache.beam:beam-sdks-java-io-mongodb (Maven): affected from 2.10.0; fixed in 2.17.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-1929/ (Markdown: https://insights.sbomify.com/CVE-2020-1929/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-1929
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-1929
- OSV: https://osv.dev/vulnerability/CVE-2020-1929

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-1929/
Summaries are generated and may contain mistakes; the official description above is the record.
