CVE-2020-1930 Command injection in Apache SpamAssassin

High 8.1 Published Updated

Attackers can execute arbitrary system commands via malicious rule configuration files, potentially gaining elevated privileges if spamd runs with them.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2020-1930?

CVE-2020-1930 is a high-severity command injection vulnerability in Apache SpamAssassin, published on 30 Jan 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

A command execution issue was found in Apache SpamAssassin prior to 3.4.3. Carefully crafted nefarious rule configuration (.cf) files can be configured to run system commands similar to CVE-2018-11805. With this bug unpatched, exploits can be injected in a number of scenarios including the same privileges as spamd is run which may be elevated though doing so remotely is difficult. In addition to upgrading to SA 3.4.4, we again recommend that users should only use update channels or 3rd party .cf files from trusted places. If you cannot upgrade, do not use 3rd party rulesets, do not use sa-compile and do not run spamd as an account with elevated privileges.

Weakness: CWE-78

Which versions are affected by CVE-2020-1930?

It affects 1 product.

Products include Apache Spamassassin.

How do I fix CVE-2020-1930?

Upgrade to a fixed version.

Upgrade, and pass arguments to programs as a list instead of through a shell. More about Command injection.

Is CVE-2020-1930 being exploited?

There is no known exploitation of CVE-2020-1930 in the wild and no public exploit code.

Sources

Also known as ALPINE-CVE-2020-1930, DEBIAN-CVE-2020-1930, GHSA-pxq8-92ff-q845, UBUNTU-CVE-2020-1930.

Is CVE-2020-1930 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free