# CVE-2020-1930: Command injection in Apache SpamAssassin

> Attackers can execute arbitrary system commands via malicious rule configuration files, potentially gaining elevated privileges if spamd runs with them.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 Jan 2020
- **Updated:** 4 Aug 2024
- **Also known as:** ALPINE-CVE-2020-1930, DEBIAN-CVE-2020-1930, GHSA-pxq8-92ff-q845, UBUNTU-CVE-2020-1930

## What is CVE-2020-1930?

CVE-2020-1930 is a high-severity command injection vulnerability in Apache SpamAssassin, published on 30 Jan 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A command execution issue was found in Apache SpamAssassin prior to 3.4.3. Carefully crafted nefarious rule configuration (.cf) files can be configured to run system commands similar to CVE-2018-11805. With this bug unpatched, exploits can be injected in a number of scenarios including the same privileges as spamd is run which may be elevated though doing so remotely is difficult. In addition to upgrading to SA 3.4.4, we again recommend that users should only use update channels or 3rd party .cf files from trusted places. If you cannot upgrade, do not use 3rd party rulesets, do not use sa-compile and do not run spamd as an account with elevated privileges.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2020-1930?

It affects 1 product.


Products: Apache Spamassassin.

## How do I fix CVE-2020-1930?

Upgrade to a fixed version.

## Is CVE-2020-1930 being exploited?

There is no known exploitation of CVE-2020-1930 in the wild and no public exploit code.

## Other vulnerabilities in Apache SpamAssassin

- [CVE-2020-1946](https://insights.sbomify.com/CVE-2020-1946/): Apache SpamAssassin has an OS Command Injection vulnerability (critical 9.8)
- [CVE-2018-11780](https://insights.sbomify.com/CVE-2018-11780/): Code injection in Apache SpamAssassin (critical 9.8)
- [CVE-2020-1931](https://insights.sbomify.com/CVE-2020-1931/): Command injection in Apache SpamAssassin (high 8.1)
- [CVE-2018-11781](https://insights.sbomify.com/CVE-2018-11781/): Apache SpamAssassin 3.4.2 fixes a local user code injection in the meta rule syntax. (high 7.8)
- [CVE-2016-1238](https://insights.sbomify.com/CVE-2016-1238/): Privilege escalation in n/a (high 7.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-1930 and fix it if it is affected.

What it is: CVE-2020-1930 is a high-severity command injection vulnerability in Apache SpamAssassin, published on 30 Jan 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-1930 in the wild and no public exploit code.

Affected product: Apache SpamAssassin. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-1930/ (Markdown: https://insights.sbomify.com/CVE-2020-1930/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-1930
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-1930
- OSV: https://osv.dev/vulnerability/CVE-2020-1930

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-1930/
Summaries are generated and may contain mistakes; the official description above is the record.
