CVE-2020-1931 Command injection in Apache SpamAssassin

High 8.1 Published Updated

Attackers can execute system commands via malicious configuration files in Apache SpamAssassin, requiring trusted sources for updates.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2020-1931?

CVE-2020-1931 is a high-severity command injection vulnerability in Apache SpamAssassin, published on 30 Jan 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

A command execution issue was found in Apache SpamAssassin prior to 3.4.3. Carefully crafted nefarious Configuration (.cf) files can be configured to run system commands similar to CVE-2018-11805. This issue is less stealthy and attempts to exploit the issue will throw warnings. Thanks to Damian Lukowski at credativ for reporting the issue ethically. With this bug unpatched, exploits can be injected in a number of scenarios though doing so remotely is difficult. In addition to upgrading to SA 3.4.4, we again recommend that users should only use update channels or 3rd party .cf files from trusted places.

Weakness: CWE-78

Which versions are affected by CVE-2020-1931?

It affects 1 product.

Products include Apache Spamassassin.

How do I fix CVE-2020-1931?

Upgrade to a fixed version.

Upgrade, and pass arguments to programs as a list instead of through a shell. More about Command injection.

Is CVE-2020-1931 being exploited?

There is no known exploitation of CVE-2020-1931 in the wild and no public exploit code.

Sources

Also known as ALPINE-CVE-2020-1931, DEBIAN-CVE-2020-1931, GHSA-p22p-qh9c-7725, UBUNTU-CVE-2020-1931.

Is CVE-2020-1931 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free