{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2020-1931 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2020-1931 is a high-severity command injection vulnerability in Apache SpamAssassin, published on 30 Jan 2020. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2020-1931 and fix it if it is affected.\n\nWhat it is: CVE-2020-1931 is a high-severity command injection vulnerability in Apache SpamAssassin, published on 30 Jan 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2020-1931 in the wild and no public exploit code.\n\nAffected product: Apache SpamAssassin. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-1931/ (Markdown: https://insights.sbomify.com/CVE-2020-1931/index.md)","id":"CVE-2020-1931","markdown":"https://insights.sbomify.com/CVE-2020-1931/index.md","name":"CVE-2020-1931","record":{"aliases":["ALPINE-CVE-2020-1931","DEBIAN-CVE-2020-1931","GHSA-p22p-qh9c-7725","UBUNTU-CVE-2020-1931"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"SpamAssassin mail filter","requires_auth":"none","summary":"Attackers can execute system commands via malicious configuration files in Apache SpamAssassin, requiring trusted sources for updates.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"spamassassin","vendor":"apache"}],"cvss":{"score":8.1,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-78","name":"Improper Neutralization of Special Elements used in an OS Command"}],"description":"A command execution issue was found in Apache SpamAssassin prior to 3.4.3. Carefully crafted nefarious Configuration (.cf) files can be configured to run system commands similar to CVE-2018-11805. This issue is less stealthy and attempts to exploit the issue will throw warnings. Thanks to Damian Lukowski at credativ for reporting the issue ethically. With this bug unpatched, exploits can be injected in a number of scenarios though doing so remotely is difficult. In addition to upgrading to SA 3.4.4, we again recommend that users should only use update channels or 3rd party .cf files from trusted places.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Command injection in Apache SpamAssassin","id":"CVE-2020-1931","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"command_injection","year":"2020"},"n_packages":0,"n_references":9,"next":{"headline":"Information disclosure in Apache Superset","id":"CVE-2020-1932"},"packages":[],"prev":{"headline":"Command injection in Apache SpamAssassin","id":"CVE-2020-1930"},"products":["Apache SpamAssassin"],"published":"2020-01-30","related":[{"cvss_score":9.8,"headline":"Apache SpamAssassin has an OS Command Injection vulnerability","id":"CVE-2020-1946","kev_date_added":null,"published":"2021-03-25"},{"cvss_score":9.8,"headline":"Code injection in Apache SpamAssassin","id":"CVE-2018-11780","kev_date_added":null,"published":"2018-09-17"},{"cvss_score":8.1,"headline":"Command injection in Apache SpamAssassin","id":"CVE-2020-1930","kev_date_added":null,"published":"2020-01-30"},{"cvss_score":7.8,"headline":"Apache SpamAssassin 3.4.2 fixes a local user code injection in the meta rule syntax.","id":"CVE-2018-11781","kev_date_added":null,"published":"2018-09-17"},{"cvss_score":7.8,"headline":"Privilege escalation in n/a","id":"CVE-2016-1238","kev_date_added":null,"published":"2016-08-02"},{"cvss_score":7.5,"headline":"Denial of service in Apache SpamAssassin","id":"CVE-2019-12420","kev_date_added":null,"published":"2019-12-12"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["Apache Software Foundation"]},"summary":"Attackers can execute system commands via malicious configuration files in Apache SpamAssassin, requiring trusted sources for updates.","url":"https://insights.sbomify.com/CVE-2020-1931/"}