# CVE-2020-19316: OS Command Injection in Laravel Framework

> Attackers can execute arbitrary OS commands via the link function in Laravel Framework, requiring an upgrade to secure the application.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 20 Dec 2021
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-w2pm-r78h-4m7v

## What is CVE-2020-19316?

CVE-2020-19316 is a high-severity command injection vulnerability in n/a, published on 20 Dec 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

OS Command injection vulnerability in function link in Filesystem.php in Laravel Framework before 5.8.17.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2020-19316?

2 open source packages ship an affected version, including laravel/framework. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `laravel/framework` | Packagist | All versions | 5.8.17 |
| `laravel/framework` | Packagist | All versions | 5.8.17 |

Products: Laravel Framework.

## How do I fix CVE-2020-19316?

Upgrade laravel/framework to 5.8.17 or later.

## Is CVE-2020-19316 being exploited?

There is no known exploitation of CVE-2020-19316 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2021-43617](https://insights.sbomify.com/CVE-2021-43617/): File upload in n/a (critical 9.8)
- [CVE-2018-6330](https://insights.sbomify.com/CVE-2018-6330/): SQL injection in n/a (high 8.8)
- [CVE-2024-13918](https://insights.sbomify.com/CVE-2024-13918/): Laravel Reflected XSS via Request Parameter in Debug-Mode Error Page (high 8.0)
- [CVE-2024-13919](https://insights.sbomify.com/CVE-2024-13919/): Laravel Reflected XSS via Route Parameter in Debug-Mode Error Page (high 8.0)
- [CVE-2025-27515](https://insights.sbomify.com/CVE-2025-27515/): Laravel has a File Validation Bypass (medium 6.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-19316 and fix it if it is affected.

What it is: CVE-2020-19316 is a high-severity command injection vulnerability in n/a, published on 20 Dec 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2020-19316 in the wild and no public exploit code.

Affected packages and fixed versions:
- laravel/framework (Packagist): affected all versions; fixed in 5.8.17
- laravel/framework (Packagist): affected all versions; fixed in 5.8.17

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-19316/ (Markdown: https://insights.sbomify.com/CVE-2020-19316/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-19316
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-19316
- OSV: https://osv.dev/vulnerability/CVE-2020-19316

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-19316/
Summaries are generated and may contain mistakes; the official description above is the record.
