CVE-2020-1932 Information disclosure in Apache Superset
Authenticated users can access an undocumented API endpoint to retrieve other users' information, including hashed passwords.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2020-1932?
CVE-2020-1932 is a medium-severity vulnerability in Apache Superset, published on 28 Jan 2020. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
An information disclosure issue was found in Apache Superset 0.34.0, 0.34.1, 0.35.0, and 0.35.1. Authenticated Apache Superset users are able to retrieve other users' information, including hashed passwords, by accessing an unused and undocumented API endpoint on Apache Superset.
Which versions are affected by CVE-2020-1932?
4 open source packages ship an affected version, including apache-superset and superset. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
apache-superset PyPI | All versions | 0.35.2 |
apache-superset PyPI | From 0.34.0 | 0.35.2 |
apache-superset PyPI | From 0.34.0 | 0.35.2 |
superset Bitnami | From 0.34.0 | 0.34.1, 0.34.2, 0.35.1, 0.35.2 |
Products include Apache Superset.
How do I fix CVE-2020-1932?
Upgrade apache-superset to 0.35.2 or later.
Is CVE-2020-1932 being exploited?
There is no known exploitation of CVE-2020-1932 in the wild and no public exploit code.
Other vulnerabilities in Apache Superset
- CVE-2023-27524 Apache Superset Insecure Default Initialization of Resource
- CVE-2022-27479 SQL injection vulnerability in chart data API
- CVE-2018-8021 Deserialization of Untrusted Data in superset
- CVE-2023-49657 Apache Superset: Stored XSS in Dashboard Title and Chart Title
- CVE-2022-43719 Apache Superset: Cross Site Request Forgery (CSRF) on accept, request access API
Sources
Also known as BIT-superset-2020-1932, GHSA-fxjm-wvj9-9c39, PYSEC-2020-224.