# CVE-2020-1932: Information disclosure in Apache Superset

> Authenticated users can access an undocumented API endpoint to retrieve other users' information, including hashed passwords.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Jan 2020
- **Updated:** 4 Aug 2024
- **Also known as:** BIT-superset-2020-1932, GHSA-fxjm-wvj9-9c39, PYSEC-2020-224

## What is CVE-2020-1932?

CVE-2020-1932 is a medium-severity vulnerability in Apache Superset, published on 28 Jan 2020. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

An information disclosure issue was found in Apache Superset 0.34.0, 0.34.1, 0.35.0, and 0.35.1. Authenticated Apache Superset users are able to retrieve other users' information, including hashed passwords, by accessing an unused and undocumented API endpoint on Apache Superset.

## Which versions are affected by CVE-2020-1932?

4 open source packages ship an affected version, including apache-superset and superset. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache-superset` | PyPI | All versions | 0.35.2 |
| `apache-superset` | PyPI | From 0.34.0 | 0.35.2 |
| `apache-superset` | PyPI | From 0.34.0 | 0.35.2 |
| `superset` | Bitnami | From 0.34.0 | 0.34.1, 0.34.2, 0.35.1, 0.35.2 |

Products: Apache Superset.

## How do I fix CVE-2020-1932?

Upgrade apache-superset to 0.35.2 or later.

## Is CVE-2020-1932 being exploited?

There is no known exploitation of CVE-2020-1932 in the wild and no public exploit code.

## Other vulnerabilities in Apache Superset

- [CVE-2023-27524](https://insights.sbomify.com/CVE-2023-27524/): Apache Superset Insecure Default Initialization of Resource (high 8.9, exploited in the wild)
- [CVE-2022-27479](https://insights.sbomify.com/CVE-2022-27479/): SQL injection vulnerability in chart data API (critical 9.8)
- [CVE-2018-8021](https://insights.sbomify.com/CVE-2018-8021/): Deserialization of Untrusted Data in superset (critical 9.8)
- [CVE-2023-49657](https://insights.sbomify.com/CVE-2023-49657/): Apache Superset: Stored XSS in Dashboard Title and Chart Title (critical 9.6)
- [CVE-2022-43719](https://insights.sbomify.com/CVE-2022-43719/): Apache Superset: Cross Site Request Forgery (CSRF) on accept, request access API (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-1932 and fix it if it is affected.

What it is: CVE-2020-1932 is a medium-severity vulnerability in Apache Superset, published on 28 Jan 2020. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-1932 in the wild and no public exploit code.

Affected packages and fixed versions:
- apache-superset (PyPI): affected all versions; fixed in 0.35.2
- apache-superset (PyPI): affected from 0.34.0; fixed in 0.35.2
- apache-superset (PyPI): affected from 0.34.0; fixed in 0.35.2
- superset (Bitnami): affected from 0.34.0; fixed in 0.34.1, 0.34.2, 0.35.1, 0.35.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-1932/ (Markdown: https://insights.sbomify.com/CVE-2020-1932/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-1932
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-1932
- OSV: https://osv.dev/vulnerability/CVE-2020-1932

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-1932/
Summaries are generated and may contain mistakes; the official description above is the record.
