CVE-2020-1933 Cross-site scripting in Apache NiFi

Medium 6.1 Published Updated

An attacker can inject malicious scripts into the Apache NiFi UI via an authenticated user in Firefox, potentially leading to code execution or account takeover.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2020-1933?

CVE-2020-1933 is a medium-severity cross-site scripting vulnerability in Apache Nifi, published on 28 Jan 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

A XSS vulnerability was found in Apache NiFi 1.0.0 to 1.10.0. Malicious scripts could be injected to the UI through action by an unaware authenticated user in Firefox. Did not appear to occur in other browsers.

Weakness: CWE-79

Which versions are affected by CVE-2020-1933?

3 open source packages ship an affected version, including org.apache.nifi:nifi and nifi. It affects 1 product.

PackageAffectedFixed in
org.apache.nifi:nifi MavenFrom 1.0.01.11.0
org.apache.nifi:nifi MavenFrom 1.0.01.11.0
nifi BitnamiFrom 1.0.0 to 1.10.0None

Products include Apache Nifi.

How do I fix CVE-2020-1933?

Upgrade org.apache.nifi:nifi to 1.11.0 or later.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2020-1933 being exploited?

There is no known exploitation of CVE-2020-1933 in the wild and no public exploit code.

All Apache Nifi vulnerabilities

Sources

Also known as BIT-nifi-2020-1933, GHSA-pqhq-xx62-2v2p.

Is CVE-2020-1933 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free