CVE-2020-1944 Other in Apache Traffic Server
Attackers can bypass security controls via HTTP request smuggling in Apache Traffic Server, requiring an upgrade to patched versions.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2020-1944?
CVE-2020-1944 is a critical vulnerability in Apache Traffic Server, published on 23 Mar 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
There is a vulnerability in Apache Traffic Server 6.0.0 to 6.2.3, 7.0.0 to 7.1.8, and 8.0.0 to 8.0.5 with a smuggling attack and Transfer-Encoding and Content length headers. Upgrade to versions 7.1.9 and 8.0.6 or later versions.
Weakness: CWE-444
Which versions are affected by CVE-2020-1944?
It affects 2 products.
Products include Apache Traffic Server, Debian Debian Linux.
How do I fix CVE-2020-1944?
Upgrade to a fixed version.
Is CVE-2020-1944 being exploited?
There is no known exploitation of CVE-2020-1944 in the wild and no public exploit code.
Other vulnerabilities in Apache Traffic Server
Sources
Also known as DEBIAN-CVE-2020-1944, GHSA-6gpv-f676-prm8, UBUNTU-CVE-2020-1944.