# CVE-2020-1948: Deserialization of Untrusted Data in Apache Dubbo

> Attackers can execute arbitrary code by sending malicious RPC requests with crafted parameters to vulnerable Dubbo services.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Jul 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-whww-v56c-cgv2

## What is CVE-2020-1948?

CVE-2020-1948 is a critical unsafe deserialization vulnerability in Apache Dubbo, published on 14 Jul 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

This vulnerability can affect all Dubbo users stay on version 2.7.6 or lower. An attacker can send RPC requests with unrecognized service name or method name along with some malicious parameter payloads. When the malicious parameter is deserialized, it will execute some malicious code. More details can be found below.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2020-1948?

4 open source packages ship an affected version, including org.apache.dubbo:dubbo and org.apache.dubbo:dubbo-common. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.dubbo:dubbo` | Maven | All versions | 2.7.7 |
| `org.apache.dubbo:dubbo` | Maven | All versions | 2.7.7 |
| `org.apache.dubbo:dubbo-common` | Maven | All versions | 2.7.7 |
| `org.apache.dubbo:dubbo-common` | Maven | All versions | 2.7.7 |

Products: Apache Dubbo.

## How do I fix CVE-2020-1948?

Upgrade org.apache.dubbo:dubbo to 2.7.7 or later.

## Is CVE-2020-1948 being exploited?

There is no known exploitation of CVE-2020-1948 in the wild and no public exploit code.

Public exploit code:

- https://github.com/ctlyz123/CVE-2020-1948 (github_poc): https://github.com/ctlyz123/CVE-2020-1948
- Apache Dubbo CVE-2020-1948 漏洞测试环境，亲测可用。 (github_poc): https://github.com/txrw/Dubbo-CVE-2020-1948
- https://github.com/M3g4Byt3/cve-2020-1948-poc (github_poc): https://github.com/M3g4Byt3/cve-2020-1948-poc
- [CVE-2020-1948] Apache Dubbo Provider default deserialization cause RCE (github_poc): https://github.com/keloke/Dubbo-deserialization

## Other vulnerabilities in Apache Dubbo

- [CVE-2023-29234](https://insights.sbomify.com/CVE-2023-29234/): Bypass serialize checks in Apache Dubbo (critical 9.8)
- [CVE-2023-46279](https://insights.sbomify.com/CVE-2023-46279/): Apache Dubbo: Bypass deny serialize list check in Apache Dubbo (critical 9.8)
- [CVE-2021-32824](https://insights.sbomify.com/CVE-2021-32824/): Regular expression Denial of Service in MooTools (critical 9.8)
- [CVE-2022-39198](https://insights.sbomify.com/CVE-2022-39198/): Apache Dubbo Hession Deserialization Vulnerability Gadgets Bypass (critical 9.8)
- [CVE-2021-43297](https://insights.sbomify.com/CVE-2021-43297/): Dubbo Hessian cause RCE when parse error (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-1948 and fix it if it is affected.

What it is: CVE-2020-1948 is a critical unsafe deserialization vulnerability in Apache Dubbo, published on 14 Jul 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-1948 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.dubbo:dubbo (Maven): affected all versions; fixed in 2.7.7
- org.apache.dubbo:dubbo (Maven): affected all versions; fixed in 2.7.7
- org.apache.dubbo:dubbo-common (Maven): affected all versions; fixed in 2.7.7
- org.apache.dubbo:dubbo-common (Maven): affected all versions; fixed in 2.7.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-1948/ (Markdown: https://insights.sbomify.com/CVE-2020-1948/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-1948
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-1948
- OSV: https://osv.dev/vulnerability/CVE-2020-1948

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-1948/
Summaries are generated and may contain mistakes; the official description above is the record.
