# CVE-2020-1953: Remote code execution in Apache Commons Configuration

> Attackers can execute arbitrary code by supplying malicious YAML files to applications using Apache Commons Configuration.

- **Severity:** Critical 10.0 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Mar 2020
- **Updated:** 4 Aug 2024
- **Also known as:** DEBIAN-CVE-2020-1953, GHSA-7qx4-pp76-vrqh, UBUNTU-CVE-2020-1953

## What is CVE-2020-1953?

CVE-2020-1953 is a critical unsafe deserialization vulnerability in Oracle Database Server, published on 13 Mar 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Apache Commons Configuration uses a third-party library to parse YAML files which by default allows the instantiation of classes if the YAML includes special statements. Apache Commons Configuration versions 2.2, 2.3, 2.4, 2.5, 2.6 did not change the default settings of this library. So if a YAML file was loaded from an untrusted source, it could therefore load and execute code out of the control of the host application.

## Which versions are affected by CVE-2020-1953?

2 open source packages ship an affected version, including org.apache.commons:commons-configuration2. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.commons:commons-configuration2` | Maven | From 2.2 | 2.7 |
| `org.apache.commons:commons-configuration2` | Maven | From 2.2 | 2.7 |

Products: Apache Commons Configuration, Oracle Database Server, Oracle Healthcare Foundation.

## How do I fix CVE-2020-1953?

Upgrade org.apache.commons:commons-configuration2 to 2.7 or later.

## Is CVE-2020-1953 being exploited?

There is no known exploitation of CVE-2020-1953 in the wild and no public exploit code.

## Other vulnerabilities in Oracle Database Server

- [CVE-2022-33980](https://insights.sbomify.com/CVE-2022-33980/): Apache Commons Configuration insecure interpolation defaults (critical 9.8)
- [CVE-2024-29131](https://insights.sbomify.com/CVE-2024-29131/): Apache Commons Configuration: StackOverflowError adding property in AbstractListDelimiterHandler.flattenIterator() (high 7.3)
- [CVE-2025-46392](https://insights.sbomify.com/CVE-2025-46392/): Apache Commons Configuration: Uncontrolled Resource Consumption when loading untrusted configurations in 1.x (medium 6.5)
- [CVE-2024-29133](https://insights.sbomify.com/CVE-2024-29133/): Apache Commons Configuration: StackOverflowError calling ListDelimiterHandler.flatten(Object, int) with a cyclical object tree (medium 5.4)
- [CVE-2026-45205](https://insights.sbomify.com/CVE-2026-45205/): Apache Commons Configuration: StackOverflowError for YAML input with cycles (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-1953 and fix it if it is affected.

What it is: CVE-2020-1953 is a critical unsafe deserialization vulnerability in Oracle Database Server, published on 13 Mar 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-1953 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.commons:commons-configuration2 (Maven): affected from 2.2; fixed in 2.7
- org.apache.commons:commons-configuration2 (Maven): affected from 2.2; fixed in 2.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-1953/ (Markdown: https://insights.sbomify.com/CVE-2020-1953/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-1953
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-1953
- OSV: https://osv.dev/vulnerability/CVE-2020-1953

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-1953/
Summaries are generated and may contain mistakes; the official description above is the record.
