CVE-2020-1956 Apache Kylin OS Command Injection

Exploited in the wild High 8.8 Published Updated

Attackers can execute arbitrary OS commands via RESTful APIs in Apache Kylin due to lack of input validation.

Exploited in the wild
Since 25 Mar 2022
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2020-1956?

CVE-2020-1956 is a high-severity command injection vulnerability in Apache Kylin, published on 22 May 2020. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Apache Kylin 2.3.0, and releases up to 2.6.5 and 3.0.1 has some restful apis which will concatenate os command with the user input string, a user is likely to be able to execute any os command without any protection or validation.

Weakness: CWE-78

Which versions are affected by CVE-2020-1956?

4 open source packages ship an affected version, including org.apache.kylin:kylin-core-common. It affects 1 product.

PackageAffectedFixed in
org.apache.kylin:kylin-core-common MavenAll versions2.6.6
org.apache.kylin:kylin-core-common MavenAll versions2.6.6
org.apache.kylin:kylin-core-common MavenFrom 3.0.03.0.2
org.apache.kylin:kylin-core-common MavenFrom 3.0.03.0.2

Products include Apache Kylin.

How do I fix CVE-2020-1956?

Upgrade org.apache.kylin:kylin-core-common to a fixed version for your release line: 2.6.6 or 3.0.2. US federal agencies must fix it by 15 Apr 2022.

Upgrade, and pass arguments to programs as a list instead of through a shell. More about Command injection.

Is CVE-2020-1956 being exploited?

Yes. Attackers have exploited CVE-2020-1956 in the wild since at least 25 Mar 2022.

Public exploit code: 1 Nuclei template and 1 proofs of concept on GitHub.

Sources

Also known as GHSA-gprm-xqrc-c2j3.

Is CVE-2020-1956 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free