# CVE-2020-1956: Apache Kylin OS Command Injection

> Attackers can execute arbitrary OS commands via RESTful APIs in Apache Kylin due to lack of input validation.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Yes, since 25 Mar 2022 (CISA KEV)
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 May 2020
- **Updated:** 21 Oct 2025
- **Also known as:** GHSA-gprm-xqrc-c2j3

## What is CVE-2020-1956?

CVE-2020-1956 is a high-severity command injection vulnerability in Apache Kylin, published on 22 May 2020. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Apache Kylin 2.3.0, and releases up to 2.6.5 and 3.0.1 has some restful apis which will concatenate os command with the user input string, a user is likely to be able to execute any os command without any protection or validation.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2020-1956?

4 open source packages ship an affected version, including org.apache.kylin:kylin-core-common. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.kylin:kylin-core-common` | Maven | All versions | 2.6.6 |
| `org.apache.kylin:kylin-core-common` | Maven | All versions | 2.6.6 |
| `org.apache.kylin:kylin-core-common` | Maven | From 3.0.0 | 3.0.2 |
| `org.apache.kylin:kylin-core-common` | Maven | From 3.0.0 | 3.0.2 |

Products: Apache Kylin.

## How do I fix CVE-2020-1956?

Upgrade org.apache.kylin:kylin-core-common to a fixed version for your release line: 2.6.6 or 3.0.2. US federal agencies must fix it by 15 Apr 2022.

## Is CVE-2020-1956 being exploited?

Yes. Attackers have exploited CVE-2020-1956 in the wild since at least 25 Mar 2022.

Public exploit code:

- CVE-2020-1956 (github_poc): https://github.com/b510/CVE-2020-1956
- Apache Kylin 3.0.1 - Command Injection Vulnerability (nuclei): http/cves/2020/CVE-2020-1956.yaml

## Other vulnerabilities in Apache Kylin

- [CVE-2026-62390](https://insights.sbomify.com/CVE-2026-62390/): Apache Kylin: SQL Injection Vulnerability in Catalog Cache Refresh API (critical 9.8)
- [CVE-2022-44621](https://insights.sbomify.com/CVE-2022-44621/): Apache Kylin: Command injection by Diagnosis Controller (critical 9.8)
- [CVE-2022-24697](https://insights.sbomify.com/CVE-2022-24697/): Apache Kylin vulnerable to remote code execution (critical 9.8)
- [CVE-2021-31522](https://insights.sbomify.com/CVE-2021-31522/): Apache Kylin unsafe class loading (critical 9.8)
- [CVE-2021-45456](https://insights.sbomify.com/CVE-2021-45456/): Command injection (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-1956 and fix it if it is affected.

What it is: CVE-2020-1956 is a high-severity command injection vulnerability in Apache Kylin, published on 22 May 2020. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: Yes. Attackers have exploited CVE-2020-1956 in the wild since at least 25 Mar 2022.

Affected packages and fixed versions:
- org.apache.kylin:kylin-core-common (Maven): affected all versions; fixed in 2.6.6
- org.apache.kylin:kylin-core-common (Maven): affected all versions; fixed in 2.6.6
- org.apache.kylin:kylin-core-common (Maven): affected from 3.0.0; fixed in 3.0.2
- org.apache.kylin:kylin-core-common (Maven): affected from 3.0.0; fixed in 3.0.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-1956/ (Markdown: https://insights.sbomify.com/CVE-2020-1956/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-1956
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-1956
- OSV: https://osv.dev/vulnerability/CVE-2020-1956

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-1956/
Summaries are generated and may contain mistakes; the official description above is the record.
