# CVE-2020-1958: Credentials bypass in Apache Druid

> Attackers with valid LDAP credentials can bypass authentication filters and retrieve sensitive LDAP user attributes in Apache Druid.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Apr 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-qh2g-7h5p-mxf4

## What is CVE-2020-1958?

CVE-2020-1958 is a medium-severity authentication bypass vulnerability in Apache Druid, published on 1 Apr 2020. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

When LDAP authentication is enabled in Apache Druid 0.17.0, callers of Druid APIs with a valid set of LDAP credentials can bypass the credentialsValidator.userSearch filter barrier that determines if a valid LDAP user is allowed to authenticate with Druid. They are still subject to role-based authorization checks, if configured. Callers of Druid APIs can also retrieve any LDAP attribute values of users that exist on the LDAP server, so long as that information is visible to the Druid server. This information disclosure does not require the caller itself to be a valid LDAP user.

Weakness: CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component)

## Which versions are affected by CVE-2020-1958?

2 open source packages ship an affected version, including org.apache.druid:druid. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.druid:druid` | Maven | From 0.17.0 | 0.17.1 |
| `org.apache.druid:druid` | Maven | From 0.17.0 | 0.17.1 |

Products: Apache Druid.

## How do I fix CVE-2020-1958?

Upgrade org.apache.druid:druid to 0.17.1 or later.

## Is CVE-2020-1958 being exploited?

There is no known exploitation of CVE-2020-1958 in the wild and no public exploit code.

Public exploit code:

- CVE-2020-1958 PoC (github_poc): https://github.com/ggolawski/CVE-2020-1958

## Other vulnerabilities in Apache Druid

- [CVE-2026-23906](https://insights.sbomify.com/CVE-2026-23906/): Apache Druid: Authentication Bypass via LDAP Anonymous Bind (critical 9.8)
- [CVE-2025-59390](https://insights.sbomify.com/CVE-2025-59390/): Apache Druid: Kerberos authenticaton chooses a cryptographically unsecure secret if not configured explicitly. (critical 9.8)
- [CVE-2021-26919](https://insights.sbomify.com/CVE-2021-26919/): Apache Druid Authenticated users can execute arbitrary code from malicious MySQL database systems. (high 8.8)
- [CVE-2021-25646](https://insights.sbomify.com/CVE-2021-25646/): Authenticated users can override system configurations in their requests which allows them to execute arbitrary code. (high 8.8)
- [CVE-2024-45537](https://insights.sbomify.com/CVE-2024-45537/): Apache Druid: Users can provide MySQL JDBC properties not on allow list (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-1958 and fix it if it is affected.

What it is: CVE-2020-1958 is a medium-severity authentication bypass vulnerability in Apache Druid, published on 1 Apr 2020. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-1958 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.druid:druid (Maven): affected from 0.17.0; fixed in 0.17.1
- org.apache.druid:druid (Maven): affected from 0.17.0; fixed in 0.17.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-1958/ (Markdown: https://insights.sbomify.com/CVE-2020-1958/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-1958
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-1958
- OSV: https://osv.dev/vulnerability/CVE-2020-1958

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-1958/
Summaries are generated and may contain mistakes; the official description above is the record.
