# CVE-2020-1959: Expression Language Injection in Apache Syncope

> Unauthenticated attackers can achieve remote code execution in Apache Syncope by injecting Java EL expressions into custom constraint violation error messages.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 May 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-vjqw-r3ww-wj2w

## What is CVE-2020-1959?

CVE-2020-1959 is a critical code injection vulnerability in Apache Syncope, published on 4 May 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A Server-Side Template Injection was identified in Apache Syncope prior to 2.1.6 enabling attackers to inject arbitrary Java EL expressions, leading to an unauthenticated Remote Code Execution (RCE) vulnerability. Apache Syncope uses Java Bean Validation (JSR 380) custom constraint validators. When building custom constraint violation error messages, they support different types of interpolation, including Java EL expressions. Therefore, if an attacker can inject arbitrary data in the error message template being passed, they will be able to run arbitrary Java code.

Weakness: CWE-917 (Improper Neutralization of Special Elements used in an Expression Language Statement)

## Which versions are affected by CVE-2020-1959?

2 open source packages ship an affected version, including org.apache.syncope:syncope-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.syncope:syncope-core` | Maven | All versions | 2.1.6 |
| `org.apache.syncope:syncope-core` | Maven | All versions | 2.1.6 |

Products: Apache Syncope.

## How do I fix CVE-2020-1959?

Upgrade org.apache.syncope:syncope-core to 2.1.6 or later.

## Is CVE-2020-1959 being exploited?

There is no known exploitation of CVE-2020-1959 in the wild and no public exploit code.

## Other vulnerabilities in Apache Syncope

- [CVE-2026-53405](https://insights.sbomify.com/CVE-2026-53405/): Apache Syncope: Remote Code Execution via Flowable BPMN Groovy ScriptTask (critical 9.8)
- [CVE-2026-53421](https://insights.sbomify.com/CVE-2026-53421/): Apache Syncope: Remote Code Execution via Scripted Connector (critical 9.8)
- [CVE-2026-57308](https://insights.sbomify.com/CVE-2026-57308/): Apache Syncope: SQL injection vulnerability in Audit Events search (critical 9.8)
- [CVE-2026-62183](https://insights.sbomify.com/CVE-2026-62183/): Apache Syncope: User self-service privilege escalation (critical 9.8)
- [CVE-2026-63071](https://insights.sbomify.com/CVE-2026-63071/): Apache Syncope: RCE via Groovy Sandbox bypass (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-1959 and fix it if it is affected.

What it is: CVE-2020-1959 is a critical code injection vulnerability in Apache Syncope, published on 4 May 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-1959 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.syncope:syncope-core (Maven): affected all versions; fixed in 2.1.6
- org.apache.syncope:syncope-core (Maven): affected all versions; fixed in 2.1.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-1959/ (Markdown: https://insights.sbomify.com/CVE-2020-1959/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-1959
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-1959
- OSV: https://osv.dev/vulnerability/CVE-2020-1959

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-1959/
Summaries are generated and may contain mistakes; the official description above is the record.
