# CVE-2020-1960: Command injection in Apache Flink

> Local attackers can perform a man-in-the-middle attack on JMX connections to extract credentials and data when the JMXReporter is enabled.

- **Severity:** Medium 4.7 (`CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 May 2020
- **Updated:** 4 Aug 2024
- **Also known as:** BIT-flink-2020-1960, GHSA-6g88-99wj-8mgg

## What is CVE-2020-1960?

CVE-2020-1960 is a medium-severity vulnerability in Apache Flink, published on 14 May 2020. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

A vulnerability in Apache Flink (1.1.0 to 1.1.5, 1.2.0 to 1.2.1, 1.3.0 to 1.3.3, 1.4.0 to 1.4.2, 1.5.0 to 1.5.6, 1.6.0 to 1.6.4, 1.7.0 to 1.7.2, 1.8.0 to 1.8.3, 1.9.0 to 1.9.2, 1.10.0) where, when running a process with an enabled JMXReporter, with a port configured via metrics.reporter.reporter_name>.port, an attacker with local access to the machine and JMX port can execute a man-in-the-middle attack using a specially crafted request to rebind the JMXRMI registry to one under the attacker's control. This compromises any connection established to the process via JMX, allowing extraction of credentials and any other transferred data.

## Which versions are affected by CVE-2020-1960?

5 open source packages ship an affected version, including org.apache.flink:flink-core and flink. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.flink:flink-core` | Maven | All versions | 1.9.3 |
| `org.apache.flink:flink-core` | Maven | All versions | 1.9.3 |
| `org.apache.flink:flink-core` | Maven | From 1.10.0 | 1.10.1 |
| `org.apache.flink:flink-core` | Maven | From 1.10.0 | 1.10.1 |
| `flink` | Bitnami | From 1.1.0 | 1.1.6, 1.2.2, 1.3.4, 1.4.3, 1.5.7, 1.6.5, 1.7.3, 1.8.4, 1.9.3, 1.10.1 |

Products: Apache Flink.

## How do I fix CVE-2020-1960?

Upgrade org.apache.flink:flink-core to a fixed version for your release line: 1.9.3 or 1.10.1.

## Is CVE-2020-1960 being exploited?

There is no known exploitation of CVE-2020-1960 in the wild and no public exploit code.

## Other vulnerabilities in Apache Flink

- [CVE-2020-17519](https://insights.sbomify.com/CVE-2020-17519/): Apache Flink Improper Access Control (critical 9.1, exploited in the wild)
- [CVE-2026-35194](https://insights.sbomify.com/CVE-2026-35194/): Apache Flink: Remote code execution via SQL injection in code generation (high 8.1)
- [CVE-2020-17518](https://insights.sbomify.com/CVE-2020-17518/): Apache Flink directory traversal attack: remote file writing through the REST API (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-1960 and fix it if it is affected.

What it is: CVE-2020-1960 is a medium-severity vulnerability in Apache Flink, published on 14 May 2020. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-1960 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.flink:flink-core (Maven): affected all versions; fixed in 1.9.3
- org.apache.flink:flink-core (Maven): affected all versions; fixed in 1.9.3
- org.apache.flink:flink-core (Maven): affected from 1.10.0; fixed in 1.10.1
- org.apache.flink:flink-core (Maven): affected from 1.10.0; fixed in 1.10.1
- flink (Bitnami): affected from 1.1.0; fixed in 1.1.6, 1.2.2, 1.3.4, 1.4.3, 1.5.7, 1.6.5, 1.7.3, 1.8.4, 1.9.3, 1.10.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-1960/ (Markdown: https://insights.sbomify.com/CVE-2020-1960/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-1960
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-1960
- OSV: https://osv.dev/vulnerability/CVE-2020-1960

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-1960/
Summaries are generated and may contain mistakes; the official description above is the record.
