CVE-2020-1961 Injection in Apache Syncope

Critical 9.8 Published Updated

Attackers can inject arbitrary JEXL expressions into mail templates to achieve remote code execution in Apache Syncope.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2020-1961?

CVE-2020-1961 is a critical code injection vulnerability in Apache Syncope, published on 4 May 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Vulnerability to Server-Side Template Injection on Mail templates for Apache Syncope 2.0.X releases prior to 2.0.15, 2.1.X releases prior to 2.1.6, enabling attackers to inject arbitrary JEXL expressions, leading to Remote Code Execution (RCE) was discovered.

Weakness: CWE-74

Which versions are affected by CVE-2020-1961?

4 open source packages ship an affected version, including org.apache.syncope:syncope-core. It affects 1 product.

PackageAffectedFixed in
org.apache.syncope:syncope-core MavenFrom 2.0.02.0.15
org.apache.syncope:syncope-core MavenFrom 2.0.02.0.15
org.apache.syncope:syncope-core MavenFrom 2.1.02.1.6
org.apache.syncope:syncope-core MavenFrom 2.1.02.1.6

Products include Apache Syncope.

How do I fix CVE-2020-1961?

Upgrade org.apache.syncope:syncope-core to a fixed version for your release line: 2.0.15 or 2.1.6.

Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.

Is CVE-2020-1961 being exploited?

There is no known exploitation of CVE-2020-1961 in the wild and no public exploit code.

Sources

Also known as GHSA-4w4p-xwrr-9crh.

Is CVE-2020-1961 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free