CVE-2020-1967 Segmentation fault in SSL_check_chain
- Exploited in the wild
- Not known
- Fix
- Available
What is CVE-2020-1967?
CVE-2020-1967 is a high-severity vulnerability in Broadcom Fabric Operating System, published on 21 Apr 2020.
Official description
Server or client applications that call the SSL_check_chain() function during or after a TLS 1.3 handshake may crash due to a NULL pointer dereference as a result of incorrect handling of the "signature_algorithms_cert" TLS extension. The crash occurs if an invalid or unrecognised signature algorithm is received from the peer. This could be exploited by a malicious peer in a Denial of Service attack. OpenSSL version 1.1.1d, 1.1.1e, and 1.1.1f are affected by this issue. This issue did not affect OpenSSL versions prior to 1.1.1d. Fixed in OpenSSL 1.1.1g (Affected 1.1.1d-1.1.1f).
Weakness: CWE-476
Which versions are affected by CVE-2020-1967?
3 open source packages ship an affected version, including openssl-src. It affects 26 products.
| Package | Affected | Fixed in |
|---|---|---|
openssl-src crates.io | From 111.6.0 | 111.9.0 |
openssl-src crates.io | From 111.6.0 | 111.9.0 |
openssl-src crates.io | From 111.6.0 | 111.9.0 |
Linux distribution packages (12)
rust SUSE:Linux Enterprise Module for Development Tools 15 SP1 | All versions | 1.43.1-12.1 |
rust SUSE:Linux Enterprise Module for Development Tools 15 SP2 | All versions | 1.43.1-12.1 |
openssl-1_1 SUSE:Linux Enterprise Server 12 SP4 | All versions | 1.1.1d-2.23.1 |
openssl-1_1 SUSE:Linux Enterprise Server 12 SP5 | All versions | 1.1.1d-2.23.1 |
openssl-1_1 SUSE:Linux Enterprise Server for SAP Applications 12 SP4 | All versions | 1.1.1d-2.23.1 |
openssl-1_1 SUSE:Linux Enterprise Server for SAP Applications 12 SP5 | All versions | 1.1.1d-2.23.1 |
openssl-1_1 SUSE:Linux Enterprise Software Development Kit 12 SP4 | All versions | 1.1.1d-2.23.1 |
openssl-1_1 SUSE:Linux Enterprise Software Development Kit 12 SP5 | All versions | 1.1.1d-2.23.1 |
rust openSUSE:Leap 15.1 | All versions | 1.43.1-lp151.5.13.1 |
rust-cbindgen openSUSE:Leap 15.1 | All versions | 0.14.1-lp151.8.2 |
rust openSUSE:Leap 15.2 | All versions | 1.43.1-lp152.3.5.1 |
rust-cbindgen openSUSE:Leap 15.2 | All versions | 0.14.1-lp152.2.4.1 |
Products include Broadcom Fabric Operating System, Debian Debian Linux, Fedoraproject Fedora, Freebsd Freebsd, Jdedwards Enterpriseone, Netapp Active Iq Unified Manager and 20 more.
How do I fix CVE-2020-1967?
Upgrade openssl-src to 111.9.0 or later.
Is CVE-2020-1967 being exploited?
There is no known exploitation of CVE-2020-1967 in the wild and no public exploit code.
Public exploit code: 1 proofs of concept on GitHub.
Other vulnerabilities in Broadcom Fabric Operating System
Sources
Also known as ALPINE-CVE-2020-1967, CLEANSTART-2026-FG73322, DEBIAN-CVE-2020-1967, DSA-4661-1, GHSA-jq65-29v4-4x35, JLSEC-2026-219 and 6 more.