# CVE-2020-1967: Segmentation fault in SSL_check_chain


- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 21 Apr 2020
- **Updated:** 8 Oct 2026
- **Also known as:** ALPINE-CVE-2020-1967, CLEANSTART-2026-FG73322, DEBIAN-CVE-2020-1967, DSA-4661-1, GHSA-jq65-29v4-4x35, JLSEC-2026-219, RUSTSEC-2020-0015, SUSE-SU-2020:1058-1, SUSE-SU-2020:2041-1, UBUNTU-CVE-2020-1967, openSUSE-SU-2020:0933-1, openSUSE-SU-2020:0945-1

## What is CVE-2020-1967?

CVE-2020-1967 is a high-severity vulnerability in Broadcom Fabric Operating System, published on 21 Apr 2020. 

### Official description

Server or client applications that call the SSL_check_chain() function during or after a TLS 1.3 handshake may crash due to a NULL pointer dereference as a result of incorrect handling of the "signature_algorithms_cert" TLS extension. The crash occurs if an invalid or unrecognised signature algorithm is received from the peer. This could be exploited by a malicious peer in a Denial of Service attack. OpenSSL version 1.1.1d, 1.1.1e, and 1.1.1f are affected by this issue. This issue did not affect OpenSSL versions prior to 1.1.1d. Fixed in OpenSSL 1.1.1g (Affected 1.1.1d-1.1.1f).

Weakness: CWE-476 (NULL Pointer Dereference)

## Which versions are affected by CVE-2020-1967?

3 open source packages ship an affected version, including openssl-src. It affects 26 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `openssl-src` | crates.io | From 111.6.0 | 111.9.0 |
| `openssl-src` | crates.io | From 111.6.0 | 111.9.0 |
| `openssl-src` | crates.io | From 111.6.0 | 111.9.0 |
| `rust` | SUSE:Linux Enterprise Module for Development Tools 15 SP1 | All versions | 1.43.1-12.1 |
| `rust` | SUSE:Linux Enterprise Module for Development Tools 15 SP2 | All versions | 1.43.1-12.1 |
| `openssl-1_1` | SUSE:Linux Enterprise Server 12 SP4 | All versions | 1.1.1d-2.23.1 |
| `openssl-1_1` | SUSE:Linux Enterprise Server 12 SP5 | All versions | 1.1.1d-2.23.1 |
| `openssl-1_1` | SUSE:Linux Enterprise Server for SAP Applications 12 SP4 | All versions | 1.1.1d-2.23.1 |
| `openssl-1_1` | SUSE:Linux Enterprise Server for SAP Applications 12 SP5 | All versions | 1.1.1d-2.23.1 |
| `openssl-1_1` | SUSE:Linux Enterprise Software Development Kit 12 SP4 | All versions | 1.1.1d-2.23.1 |
| `openssl-1_1` | SUSE:Linux Enterprise Software Development Kit 12 SP5 | All versions | 1.1.1d-2.23.1 |
| `rust` | openSUSE:Leap 15.1 | All versions | 1.43.1-lp151.5.13.1 |
| `rust-cbindgen` | openSUSE:Leap 15.1 | All versions | 0.14.1-lp151.8.2 |
| `rust` | openSUSE:Leap 15.2 | All versions | 1.43.1-lp152.3.5.1 |
| `rust-cbindgen` | openSUSE:Leap 15.2 | All versions | 0.14.1-lp152.2.4.1 |

Products: Broadcom Fabric Operating System, Debian Debian Linux, Fedoraproject Fedora, Freebsd Freebsd, Jdedwards Enterpriseone, Netapp Active Iq Unified Manager, Netapp E-Series Performance Analyzer, Netapp Oncommand Insight, Netapp Oncommand Workflow Automation, Netapp Smi-S Provider, Netapp Snapcenter, Netapp Steelstore Cloud Integrated Storage, Openssl Openssl, Opensuse Leap, Oracle Application Server, Oracle Enterprise Manager Base Platform, Oracle Enterprise Manager for Storage Management, Oracle Enterprise Manager Ops Center, Oracle Http Server, Oracle Jd Edwards World Security and 6 more.

## How do I fix CVE-2020-1967?

Upgrade openssl-src to 111.9.0 or later.

## Is CVE-2020-1967 being exploited?

There is no known exploitation of CVE-2020-1967 in the wild and no public exploit code.

Public exploit code:

- Proof of concept exploit about OpenSSL signature_algorithms_cert DoS flaw (CVE-2020-1967) (github_poc): https://github.com/irsl/CVE-2020-1967

## Other vulnerabilities in Broadcom Fabric Operating System

- [CVE-2025-1976](https://insights.sbomify.com/CVE-2025-1976/): Broadcom Brocade Fabric OS Code Injection (high 8.6, exploited in the wild)
- [CVE-2021-22555](https://insights.sbomify.com/CVE-2021-22555/): Linux Kernel Heap Out-of-Bounds Write (high 8.3, exploited in the wild)
- [CVE-2022-33186](https://insights.sbomify.com/CVE-2022-33186/): Command injection in Brocade Fabric OS (critical 9.8)
- [CVE-2021-27797](https://insights.sbomify.com/CVE-2021-27797/): Hardcoded credentials in Brocade Fabric OS (critical 9.8)
- [CVE-2020-15371](https://insights.sbomify.com/CVE-2020-15371/): Code injection in Brocade Fabric OS (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-1967 and fix it if it is affected.

What it is: CVE-2020-1967 is a high-severity vulnerability in Broadcom Fabric Operating System, published on 21 Apr 2020. 
Exploitation: There is no known exploitation of CVE-2020-1967 in the wild and no public exploit code.

Affected packages and fixed versions:
- openssl-src (crates.io): affected from 111.6.0; fixed in 111.9.0
- openssl-src (crates.io): affected from 111.6.0; fixed in 111.9.0
- openssl-src (crates.io): affected from 111.6.0; fixed in 111.9.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-1967/ (Markdown: https://insights.sbomify.com/CVE-2020-1967/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-1967
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-1967
- OSV: https://osv.dev/vulnerability/CVE-2020-1967

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-1967/
Summaries are generated and may contain mistakes; the official description above is the record.
