CVE-2020-1980 PAN-OS: Shell injection vulnerability in PAN-OS CLI allows execution of shell commands
A local authenticated user can inject shell commands into the PAN-OS CLI to escape the restricted shell and escalate privileges.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Local or same network only
- Victim action needed
- Not needed
- Fix
- None listed
What is CVE-2020-1980?
CVE-2020-1980 is a high-severity command injection vulnerability in Paloaltonetworks Pan-Os, published on 11 Mar 2020. It can only be exploited from the same machine or local network, with no action from the victim.
Official description
A shell command injection vulnerability in the PAN-OS CLI allows a local authenticated user to escape the restricted shell and escalate privileges. This issue affects only PAN-OS 8.1 versions earlier than PAN-OS 8.1.13. This issue does not affect PAN-OS 7.1, PAN-OS 9.0, or later PAN-OS versions. This issue is fixed in PAN-OS 8.1.13, and all later versions.
Which versions are affected by CVE-2020-1980?
It affects 1 product.
Products include Paloaltonetworks Pan-Os.
How do I fix CVE-2020-1980?
No fix has been published for CVE-2020-1980 yet. Limit exposure of the affected software until one is available.
Upgrade, and pass arguments to programs as a list instead of through a shell. More about Command injection.
Is CVE-2020-1980 being exploited?
There is no known exploitation of CVE-2020-1980 in the wild and no public exploit code.
Other vulnerabilities in Paloaltonetworks Pan-Os
- CVE-2024-3400 Palo Alto Networks PAN-OS Command Injection
- CVE-2020-2021 Palo Alto Networks PAN-OS Authentication Bypass
- CVE-2017-15944 Palo Alto Networks PAN-OS Remote Code Execution
- CVE-2026-0300 Palo Alto Networks PAN-OS Out-of-bounds Write
- CVE-2024-0012 Palo Alto Networks PAN-OS Management Interface Authentication Bypass
Sources
Also known as GHSA-qqvw-2w25-wwh8.