CVE-2020-19850 Directus API vulnerable to denial of service

Medium 6.5 Published Updated

A remote attacker can cause a denial of service in Directus API by sending a large volume of HTTP requests.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2020-19850?

CVE-2020-19850 is a medium-severity denial of service vulnerability in Monospace Directus, published on 4 Apr 2023. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

An issue found in Directus API v.2.2.0 allows a remote attacker to cause a denial of service via a great amount of HTTP requests.

Weakness: CWE-400

Which versions are affected by CVE-2020-19850?

2 open source packages ship an affected version, including directus. It affects 1 product.

PackageAffectedFixed in
directus npmFrom 2.2.02.2.1
directus npmFrom 2.2.02.2.1

Products include Monospace Directus.

How do I fix CVE-2020-19850?

Upgrade directus to 2.2.1 or later.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2020-19850 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2020-19850 exists.

All Monospace Directus vulnerabilities

Sources

Also known as GHSA-3gvp-54v2-2jrp.

Is CVE-2020-19850 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free