# CVE-2020-19850: Directus API vulnerable to denial of service

> A remote attacker can cause a denial of service in Directus API by sending a large volume of HTTP requests.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Apr 2023
- **Updated:** 14 Feb 2025
- **Also known as:** GHSA-3gvp-54v2-2jrp

## What is CVE-2020-19850?

CVE-2020-19850 is a medium-severity denial of service vulnerability in Monospace Directus, published on 4 Apr 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

An issue found in Directus API v.2.2.0 allows a remote attacker to cause a denial of service via a great amount of HTTP requests.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2020-19850?

2 open source packages ship an affected version, including directus. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `directus` | npm | From 2.2.0 | 2.2.1 |
| `directus` | npm | From 2.2.0 | 2.2.1 |

Products: Monospace Directus.

## How do I fix CVE-2020-19850?

Upgrade directus to 2.2.1 or later.

## Is CVE-2020-19850 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2020-19850 exists.

## Other vulnerabilities in Monospace Directus

- [CVE-2022-26969](https://insights.sbomify.com/CVE-2022-26969/): Insecure default value for CORS configuration (critical 9.8)
- [CVE-2025-55746](https://insights.sbomify.com/CVE-2025-55746/): Directus allows unauthenticated file upload and file modification due to lacking input sanitization (critical 9.3)
- [CVE-2026-35408](https://insights.sbomify.com/CVE-2026-35408/): Directus is Missing Cross-Origin Opener Policy (high 8.7)
- [CVE-2026-61836](https://insights.sbomify.com/CVE-2026-61836/): Directus: Authorization-dependent response served from unsegmented cache key (high 8.6)
- [CVE-2025-30353](https://insights.sbomify.com/CVE-2025-30353/): Directus's webhook trigger flows can leak sensitive data (high 8.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-19850 and fix it if it is affected.

What it is: CVE-2020-19850 is a medium-severity denial of service vulnerability in Monospace Directus, published on 4 Apr 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2020-19850 exists.

Affected packages and fixed versions:
- directus (npm): affected from 2.2.0; fixed in 2.2.1
- directus (npm): affected from 2.2.0; fixed in 2.2.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-19850/ (Markdown: https://insights.sbomify.com/CVE-2020-19850/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-19850
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-19850
- OSV: https://osv.dev/vulnerability/CVE-2020-19850

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-19850/
Summaries are generated and may contain mistakes; the official description above is the record.
