# CVE-2020-2026: Kata Containers - Guests can trick the kata-runtime into mounting the container image on any host path

> A malicious guest can trick the Kata runtime into mounting container filesystems on arbitrary host paths, enabling host code execution.

- **Severity:** High 7.8 (`CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Jun 2020
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-877x-32pm-p28x

## What is CVE-2020-2026?

CVE-2020-2026 is a high-severity path traversal vulnerability in Fedoraproject Fedora, published on 10 Jun 2020. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

A malicious guest compromised before a container creation (e.g. a malicious guest image or a guest running multiple containers) can trick the kata runtime into mounting the untrusted container filesystem on any host path, potentially allowing for code execution on the host. This issue affects: Kata Containers 1.11 versions earlier than 1.11.1; Kata Containers 1.10 versions earlier than 1.10.5; Kata Containers 1.9 and earlier versions.

Weakness: CWE-59 (Improper Link Resolution Before File Access)

## Which versions are affected by CVE-2020-2026?

6 open source packages ship an affected version, including github.com/kata-containers/runtime. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/kata-containers/runtime` | Go | All versions | 1.9.1 |
| `github.com/kata-containers/runtime` | Go | All versions | 1.9.1 |
| `github.com/kata-containers/runtime` | Go | From 1.10.0 | 1.10.6 |
| `github.com/kata-containers/runtime` | Go | From 1.10.0 | 1.10.6 |
| `github.com/kata-containers/runtime` | Go | From 1.11.0 | 1.11.1 |
| `github.com/kata-containers/runtime` | Go | From 1.11.0 | 1.11.1 |

Products: Fedoraproject Fedora, Katacontainers Runtime.

## How do I fix CVE-2020-2026?

Upgrade github.com/kata-containers/runtime to a fixed version for your release line: 1.9.1, 1.10.6 or 1.11.1.

## Is CVE-2020-2026 being exploited?

There is no known exploitation of CVE-2020-2026 in the wild and no public exploit code.

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2024-4577](https://insights.sbomify.com/CVE-2024-4577/): PHP-CGI OS Command Injection (critical 9.8, exploited in the wild)
- [CVE-2021-39226](https://insights.sbomify.com/CVE-2021-39226/): Grafana Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2019-5544](https://insights.sbomify.com/CVE-2019-5544/): VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2024-4947](https://insights.sbomify.com/CVE-2024-4947/): Google Chromium V8 Type Confusion (critical 9.6, exploited in the wild)
- [CVE-2024-4671](https://insights.sbomify.com/CVE-2024-4671/): Google Chromium Visuals Use-After-Free (critical 9.6, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-2026 and fix it if it is affected.

What it is: CVE-2020-2026 is a high-severity path traversal vulnerability in Fedoraproject Fedora, published on 10 Jun 2020. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-2026 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/kata-containers/runtime (Go): affected all versions; fixed in 1.9.1
- github.com/kata-containers/runtime (Go): affected all versions; fixed in 1.9.1
- github.com/kata-containers/runtime (Go): affected from 1.10.0; fixed in 1.10.6
- github.com/kata-containers/runtime (Go): affected from 1.10.0; fixed in 1.10.6
- github.com/kata-containers/runtime (Go): affected from 1.11.0; fixed in 1.11.1
- github.com/kata-containers/runtime (Go): affected from 1.11.0; fixed in 1.11.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-2026/ (Markdown: https://insights.sbomify.com/CVE-2020-2026/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-2026
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-2026
- OSV: https://osv.dev/vulnerability/CVE-2020-2026

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-2026/
Summaries are generated and may contain mistakes; the official description above is the record.
