# CVE-2020-2098: CSRF vulnerability in Jenkins Sounds Plugin allow OS command execution

> A CSRF vulnerability in the Jenkins Sounds Plugin allows attackers to execute arbitrary OS commands on the Jenkins server.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 15 Jan 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-x37x-3fw2-5qw2

## What is CVE-2020-2098?

CVE-2020-2098 is a high-severity vulnerability in Jenkins Sounds Plugin, published on 15 Jan 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

A cross-site request forgery vulnerability in Jenkins Sounds Plugin 0.5 and earlier allows attacker to execute arbitrary OS commands as the OS user account running Jenkins.

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2020-2098?

2 open source packages ship an affected version, including org.jenkins-ci.plugins:sounds. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:sounds` | Maven | All versions | 0.6 |
| `org.jenkins-ci.plugins:sounds` | Maven | All versions | 0.6 |

Products: Jenkins Sounds.

## How do I fix CVE-2020-2098?

Upgrade org.jenkins-ci.plugins:sounds to 0.6 or later.

## Is CVE-2020-2098 being exploited?

There is no known exploitation of CVE-2020-2098 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins Sounds Plugin

- [CVE-2020-2097](https://insights.sbomify.com/CVE-2020-2097/): Missing permission checks in Jenkins Sounds Plugin allow OS command execution (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-2098 and fix it if it is affected.

What it is: CVE-2020-2098 is a high-severity vulnerability in Jenkins Sounds Plugin, published on 15 Jan 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2020-2098 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:sounds (Maven): affected all versions; fixed in 0.6
- org.jenkins-ci.plugins:sounds (Maven): affected all versions; fixed in 0.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-2098/ (Markdown: https://insights.sbomify.com/CVE-2020-2098/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-2098
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-2098
- OSV: https://osv.dev/vulnerability/CVE-2020-2098

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-2098/
Summaries are generated and may contain mistakes; the official description above is the record.
