{"answers":{"affected":"2 open source packages ship an affected version, including io.jenkins.plugins:code-coverage-api. It affects 1 product.","exploited":"There is no known exploitation of CVE-2020-2106 in the wild and no public exploit code.","fix":"Upgrade io.jenkins.plugins:code-coverage-api to 1.1.3 or later.","what":"CVE-2020-2106 is a medium-severity cross-site scripting vulnerability in Jenkins Code Coverage API Plugin, published on 29 Jan 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2020-2106 and fix it if it is affected.\n\nWhat it is: CVE-2020-2106 is a medium-severity cross-site scripting vulnerability in Jenkins Code Coverage API Plugin, published on 29 Jan 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2020-2106 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- io.jenkins.plugins:code-coverage-api (Maven): affected all versions; fixed in 1.1.3\n- io.jenkins.plugins:code-coverage-api (Maven): affected all versions; fixed in 1.1.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-2106/ (Markdown: https://insights.sbomify.com/CVE-2020-2106/index.md)","id":"CVE-2020-2106","markdown":"https://insights.sbomify.com/CVE-2020-2106/index.md","name":"CVE-2020-2106","record":{"aliases":["GHSA-xg77-xqhq-crpr"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins Code Coverage Plugin","requires_auth":"low_privilege","summary":"Stored XSS in Jenkins Code Coverage API Plugin allows attackers with job configuration access to execute scripts in victim browsers.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"jenkins","cpe":[{"product":"code_coverage_api","vendor":"jenkins"}],"cvss":{"score":5.4,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Jenkins Code Coverage API Plugin 1.1.2 and earlier does not escape the filename of the coverage report used in its view, resulting in a stored XSS vulnerability exploitable by users able to change job configurations.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Stored XSS vulnerability in Code Coverage API Plugin","id":"CVE-2020-2106","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"xss","year":"2020"},"n_packages":2,"n_references":2,"next":{"headline":"Fortify Plugin stored credentials in plain text","id":"CVE-2020-2107"},"packages":[{"ecosystem":"Maven","fixed":["1.1.3"],"introduced":["0"],"last_affected":[],"package":"io.jenkins.plugins:code-coverage-api","purl":null,"source":"GHSA-xg77-xqhq-crpr"},{"ecosystem":"Maven","fixed":["1.1.3"],"introduced":["0"],"last_affected":[],"package":"io.jenkins.plugins:code-coverage-api","purl":"pkg:maven/io.jenkins.plugins/code-coverage-api","source":"GHSA-xg77-xqhq-crpr"}],"prev":{"headline":"Jenkins REST APIs vulnerable to clickjacking","id":"CVE-2020-2105"},"products":["Jenkins Code Coverage API Plugin"],"published":"2020-01-29","related":[{"cvss_score":8.8,"headline":"RCE vulnerability in Jenkins Code Coverage API Plugin","id":"CVE-2021-21677","kev_date_added":null,"published":"2021-08-31"},{"cvss_score":6.5,"headline":"XXE vulnerability in Jenkins Code Coverage API Plugin","id":"CVE-2020-2172","kev_date_added":null,"published":"2020-04-07"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["Jenkins project"]},"summary":"Stored XSS in Jenkins Code Coverage API Plugin allows attackers with job configuration access to execute scripts in victim browsers.","url":"https://insights.sbomify.com/CVE-2020-2106/"}