# CVE-2020-2106: Stored XSS vulnerability in Code Coverage API Plugin

> Stored XSS in Jenkins Code Coverage API Plugin allows attackers with job configuration access to execute scripts in victim browsers.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 29 Jan 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-xg77-xqhq-crpr

## What is CVE-2020-2106?

CVE-2020-2106 is a medium-severity cross-site scripting vulnerability in Jenkins Code Coverage API Plugin, published on 29 Jan 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Jenkins Code Coverage API Plugin 1.1.2 and earlier does not escape the filename of the coverage report used in its view, resulting in a stored XSS vulnerability exploitable by users able to change job configurations.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2020-2106?

2 open source packages ship an affected version, including io.jenkins.plugins:code-coverage-api. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `io.jenkins.plugins:code-coverage-api` | Maven | All versions | 1.1.3 |
| `io.jenkins.plugins:code-coverage-api` | Maven | All versions | 1.1.3 |

Products: Jenkins Code Coverage Api.

## How do I fix CVE-2020-2106?

Upgrade io.jenkins.plugins:code-coverage-api to 1.1.3 or later.

## Is CVE-2020-2106 being exploited?

There is no known exploitation of CVE-2020-2106 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins Code Coverage API Plugin

- [CVE-2021-21677](https://insights.sbomify.com/CVE-2021-21677/): RCE vulnerability in Jenkins Code Coverage API Plugin (high 8.8)
- [CVE-2020-2172](https://insights.sbomify.com/CVE-2020-2172/): XXE vulnerability in Jenkins Code Coverage API Plugin (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-2106 and fix it if it is affected.

What it is: CVE-2020-2106 is a medium-severity cross-site scripting vulnerability in Jenkins Code Coverage API Plugin, published on 29 Jan 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2020-2106 in the wild and no public exploit code.

Affected packages and fixed versions:
- io.jenkins.plugins:code-coverage-api (Maven): affected all versions; fixed in 1.1.3
- io.jenkins.plugins:code-coverage-api (Maven): affected all versions; fixed in 1.1.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-2106/ (Markdown: https://insights.sbomify.com/CVE-2020-2106/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-2106
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-2106
- OSV: https://osv.dev/vulnerability/CVE-2020-2106

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-2106/
Summaries are generated and may contain mistakes; the official description above is the record.
