# CVE-2020-2110: Improper Input Validation in Jenkins Script Security Plugin

> Attackers can bypass Jenkins Script Security Plugin sandbox restrictions to execute arbitrary code via AST transforming annotations.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Feb 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-qvmf-36h5-3f5v

## What is CVE-2020-2110?

CVE-2020-2110 is a high-severity vulnerability in Jenkins Script Security Plugin, published on 12 Feb 2020. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Sandbox protection in Jenkins Script Security Plugin 1.69 and earlier could be circumvented during the script compilation phase by applying AST transforming annotations to imports or by using them inside of other annotations.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2020-2110?

2 open source packages ship an affected version, including org.jenkins-ci.plugins:script-security. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:script-security` | Maven | All versions | 1.70 |
| `org.jenkins-ci.plugins:script-security` | Maven | All versions | 1.70 |

Products: Jenkins Script Security.

## How do I fix CVE-2020-2110?

Upgrade org.jenkins-ci.plugins:script-security to 1.70 or later.

## Is CVE-2020-2110 being exploited?

There is no known exploitation of CVE-2020-2110 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins Script Security Plugin

- [CVE-2019-1003029](https://insights.sbomify.com/CVE-2019-1003029/): Jenkins Script Security Plugin Sandbox Bypass (critical 9.9, exploited in the wild)
- [CVE-2022-43401](https://insights.sbomify.com/CVE-2022-43401/): Sandbox bypass vulnerabilities in Jenkins Script Security Plugin and in Pipeline: Groovy Plugin (critical 9.9)
- [CVE-2022-43403](https://insights.sbomify.com/CVE-2022-43403/): Jenkins Script Security Plugin sandbox bypass vulnerability (critical 9.9)
- [CVE-2022-43404](https://insights.sbomify.com/CVE-2022-43404/): Sandbox bypass vulnerabilities in Jenkins Script Security Plugin and in Pipeline: Groovy Plugin (critical 9.9)
- [CVE-2020-2279](https://insights.sbomify.com/CVE-2020-2279/): Sandbox bypass vulnerability in Jenkins Script Security Plugin (critical 9.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-2110 and fix it if it is affected.

What it is: CVE-2020-2110 is a high-severity vulnerability in Jenkins Script Security Plugin, published on 12 Feb 2020. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-2110 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:script-security (Maven): affected all versions; fixed in 1.70
- org.jenkins-ci.plugins:script-security (Maven): affected all versions; fixed in 1.70

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-2110/ (Markdown: https://insights.sbomify.com/CVE-2020-2110/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-2110
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-2110
- OSV: https://osv.dev/vulnerability/CVE-2020-2110

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-2110/
Summaries are generated and may contain mistakes; the official description above is the record.
