{"answers":{"affected":"2 open source packages ship an affected version, including org.jenkins-ci.plugins:subversion. It affects 1 product.","exploited":"There is no known exploitation of CVE-2020-2111 in the wild and no public exploit code.","fix":"Upgrade org.jenkins-ci.plugins:subversion to 2.13.1 or later.","what":"CVE-2020-2111 is a medium-severity cross-site scripting vulnerability in Jenkins Subversion Plugin, published on 12 Feb 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2020-2111 and fix it if it is affected.\n\nWhat it is: CVE-2020-2111 is a medium-severity cross-site scripting vulnerability in Jenkins Subversion Plugin, published on 12 Feb 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2020-2111 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.jenkins-ci.plugins:subversion (Maven): affected all versions; fixed in 2.13.1\n- org.jenkins-ci.plugins:subversion (Maven): affected all versions; fixed in 2.13.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-2111/ (Markdown: https://insights.sbomify.com/CVE-2020-2111/index.md)","id":"CVE-2020-2111","markdown":"https://insights.sbomify.com/CVE-2020-2111/index.md","name":"CVE-2020-2111","record":{"aliases":["GHSA-x3pr-fcgm-wjgc"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins Subversion Plugin","requires_auth":"low_privilege","summary":"Stored cross-site scripting in Jenkins Subversion Plugin allows attackers to inject malicious scripts via unescaped error messages in form validation.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"jenkins","cpe":[{"product":"subversion","vendor":"jenkins"}],"cvss":{"score":5.4,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Jenkins Subversion Plugin 2.13.0 and earlier does not escape the error message for the Project Repository Base URL field form validation, resulting in a stored cross-site scripting vulnerability.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Subversion Plugin stored XSS vulnerability","id":"CVE-2020-2111","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"xss","year":"2020"},"n_packages":2,"n_references":2,"next":{"headline":"Jenkins Git Parameter Plugin vulnerable to Stored cross-site scripting (XSS)","id":"CVE-2020-2112"},"packages":[{"ecosystem":"Maven","fixed":["2.13.1"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:subversion","purl":null,"source":"GHSA-x3pr-fcgm-wjgc"},{"ecosystem":"Maven","fixed":["2.13.1"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:subversion","purl":"pkg:maven/org.jenkins-ci.plugins/subversion","source":"GHSA-x3pr-fcgm-wjgc"}],"prev":{"headline":"Improper Input Validation in Jenkins Script Security Plugin","id":"CVE-2020-2110"},"products":["Jenkins Subversion Plugin"],"published":"2020-02-12","related":[{"cvss_score":7.5,"headline":"Path traversal vulnerability in Jenkins Subversion Plugin allows reading arbitrary files","id":"CVE-2021-21698","kev_date_added":null,"published":"2021-11-04"},{"cvss_score":6.5,"headline":"XXE vulnerability in Jenkins Subversion Plugin","id":"CVE-2020-2304","kev_date_added":null,"published":"2020-11-04"},{"cvss_score":6.5,"headline":"Jenkins Subversion Plugin Cross-Site Request Forgery vulnerability","id":"CVE-2017-1000085","kev_date_added":null,"published":"2017-10-04"},{"cvss_score":5.3,"headline":"Jenkins Subversion Plugin Incorrect Authorization vulnerability","id":"CVE-2018-1000111","kev_date_added":null,"published":"2018-03-13"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["Jenkins project"]},"summary":"Stored cross-site scripting in Jenkins Subversion Plugin allows attackers to inject malicious scripts via unescaped error messages in form validation.","url":"https://insights.sbomify.com/CVE-2020-2111/"}