# CVE-2020-2113: Jenkins Git Parameter Plugin vulnerable to stored cross-site scripting (XSS)

> Stored XSS in Jenkins Git Parameter Plugin allows attackers with Job/Configure permission to execute scripts in other users' browsers.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 12 Feb 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-fgxc-mxvw-55mv

## What is CVE-2020-2113?

CVE-2020-2113 is a medium-severity cross-site scripting vulnerability in Jenkins Git Parameter Plugin, published on 12 Feb 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Jenkins Git Parameter Plugin 0.9.11 and earlier does not escape the default value shown on the UI, resulting in a stored cross-site scripting vulnerability exploitable by users with Job/Configure permission.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2020-2113?

2 open source packages ship an affected version, including org.jenkins-ci.tools:git-parameter. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.tools:git-parameter` | Maven | All versions | 0.9.12 |
| `org.jenkins-ci.tools:git-parameter` | Maven | All versions | 0.9.12 |

Products: Jenkins Git Parameter.

## How do I fix CVE-2020-2113?

Upgrade org.jenkins-ci.tools:git-parameter to 0.9.12 or later.

## Is CVE-2020-2113 being exploited?

There is no known exploitation of CVE-2020-2113 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins Git Parameter Plugin

- [CVE-2025-53652](https://insights.sbomify.com/CVE-2025-53652/): Jenkins Git Parameter Plugin vulnerable to code injection due to inexhaustive parameter check (high 8.2)
- [CVE-2022-29040](https://insights.sbomify.com/CVE-2022-29040/): Stored XSS vulnerability in Jenkins Git Parameter Plugin (medium 5.4)
- [CVE-2020-2238](https://insights.sbomify.com/CVE-2020-2238/): Stored XSS vulnerability in Jenkins Git Parameter Plugin (medium 5.4)
- [CVE-2020-2112](https://insights.sbomify.com/CVE-2020-2112/): Jenkins Git Parameter Plugin vulnerable to Stored cross-site scripting (XSS) (medium 5.4)
- [CVE-2026-57286](https://insights.sbomify.com/CVE-2026-57286/): Jenkins Git Parameter Plugin has a missing permission check that allows listing SCM branch and tag names (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-2113 and fix it if it is affected.

What it is: CVE-2020-2113 is a medium-severity cross-site scripting vulnerability in Jenkins Git Parameter Plugin, published on 12 Feb 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2020-2113 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.tools:git-parameter (Maven): affected all versions; fixed in 0.9.12
- org.jenkins-ci.tools:git-parameter (Maven): affected all versions; fixed in 0.9.12

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-2113/ (Markdown: https://insights.sbomify.com/CVE-2020-2113/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-2113
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-2113
- OSV: https://osv.dev/vulnerability/CVE-2020-2113

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-2113/
Summaries are generated and may contain mistakes; the official description above is the record.
