# CVE-2020-2114: Jenkins S3 Publisher Plugin transmits credentials in plain text during configuration

> The Jenkins S3 publisher plugin exposes configured credentials in plain text within the global configuration form, allowing attackers to steal sensitive access keys.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Feb 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-ffr6-8cv5-j637

## What is CVE-2020-2114?

CVE-2020-2114 is a high-severity vulnerability in Jenkins S3 publisher Plugin, published on 12 Feb 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Jenkins S3 publisher Plugin 0.11.4 and earlier transmits configured credentials in plain text as part of the global Jenkins configuration form, potentially resulting in their exposure.

Weakness: CWE-522 (Insufficiently Protected Credentials)

## Which versions are affected by CVE-2020-2114?

2 open source packages ship an affected version, including org.jenkins-ci.plugins:s3. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:s3` | Maven | All versions | 0.11.5 |
| `org.jenkins-ci.plugins:s3` | Maven | All versions | 0.11.5 |

Products: Jenkins S3 Publisher.

## How do I fix CVE-2020-2114?

Upgrade org.jenkins-ci.plugins:s3 to 0.11.5 or later.

## Is CVE-2020-2114 being exploited?

There is no known exploitation of CVE-2020-2114 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins S3 publisher Plugin

- [CVE-2018-1000177](https://insights.sbomify.com/CVE-2018-1000177/): Stored XSS vulnerability in Jenkins S3 Publisher Plugin (medium 5.4)
- [CVE-2021-21650](https://insights.sbomify.com/CVE-2021-21650/): Missing Authorization in Jenkins S3 publisher Plugin (medium 4.3)
- [CVE-2021-21651](https://insights.sbomify.com/CVE-2021-21651/): Missing Authorization in Jenkins S3 publisher Plugin (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-2114 and fix it if it is affected.

What it is: CVE-2020-2114 is a high-severity vulnerability in Jenkins S3 publisher Plugin, published on 12 Feb 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-2114 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:s3 (Maven): affected all versions; fixed in 0.11.5
- org.jenkins-ci.plugins:s3 (Maven): affected all versions; fixed in 0.11.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-2114/ (Markdown: https://insights.sbomify.com/CVE-2020-2114/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-2114
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-2114
- OSV: https://osv.dev/vulnerability/CVE-2020-2114

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-2114/
Summaries are generated and may contain mistakes; the official description above is the record.
