# CVE-2020-21146: Feehi CMS vulnerable to Cross-site Scripting in Username Field

> An attacker can inject JavaScript via the username field in Feehi CMS, leading to script execution when posts are viewed.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 21 Jan 2021
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-v762-47vh-j7q3

## What is CVE-2020-21146?

CVE-2020-21146 is a medium-severity cross-site scripting vulnerability in n/a, published on 21 Jan 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Feehi CMS 2.0.8 is affected by a cross-site scripting (XSS) vulnerability. When the user name is inserted as JavaScript code, browsing the post will trigger the XSS.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2020-21146?

2 open source packages ship an affected version, including feehi/cms. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `feehi/cms` | Packagist | All versions | 2.0.8.1 |
| `feehi/cms` | Packagist | All versions | 2.0.8.1 |

Products: Feehi Feehi Cms.

## How do I fix CVE-2020-21146?

Upgrade feehi/cms to 2.0.8.1 or later.

## Is CVE-2020-21146 being exploited?

There is no known exploitation of CVE-2020-21146 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2021-30108](https://insights.sbomify.com/CVE-2021-30108/): Server-Side Request Forgery in Feehi CMS (critical 9.1)
- [CVE-2022-34971](https://insights.sbomify.com/CVE-2022-34971/): Feehi CMS arbitrary code execution via crafted PHP file (high 8.8)
- [CVE-2020-22643](https://insights.sbomify.com/CVE-2020-22643/): Feehi CMS arbitrary file upload vulnerability (high 7.2)
- [CVE-2022-38796](https://insights.sbomify.com/CVE-2022-38796/): Feehi CMS host header injection vulnerability (medium 6.1)
- [CVE-2026-31313](https://insights.sbomify.com/CVE-2026-31313/): Feehi CMS has an authenticated stored cross-site scripting (XSS) vulnerability via the creation/editing module (medium 5.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-21146 and fix it if it is affected.

What it is: CVE-2020-21146 is a medium-severity cross-site scripting vulnerability in n/a, published on 21 Jan 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2020-21146 in the wild and no public exploit code.

Affected packages and fixed versions:
- feehi/cms (Packagist): affected all versions; fixed in 2.0.8.1
- feehi/cms (Packagist): affected all versions; fixed in 2.0.8.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-21146/ (Markdown: https://insights.sbomify.com/CVE-2020-21146/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-21146
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-21146
- OSV: https://osv.dev/vulnerability/CVE-2020-21146

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-21146/
Summaries are generated and may contain mistakes; the official description above is the record.
