{"answers":{"affected":"2 open source packages ship an affected version, including org.jenkins-ci.plugins:nunit. It affects 1 product.","exploited":"There is no known exploitation of CVE-2020-2115 in the wild and no public exploit code.","fix":"Upgrade org.jenkins-ci.plugins:nunit to 0.26 or later.","what":"CVE-2020-2115 is a high-severity vulnerability in Jenkins NUnit Plugin, published on 12 Feb 2020. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2020-2115 and fix it if it is affected.\n\nWhat it is: CVE-2020-2115 is a high-severity vulnerability in Jenkins NUnit Plugin, published on 12 Feb 2020. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2020-2115 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.jenkins-ci.plugins:nunit (Maven): affected all versions; fixed in 0.26\n- org.jenkins-ci.plugins:nunit (Maven): affected all versions; fixed in 0.26\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-2115/ (Markdown: https://insights.sbomify.com/CVE-2020-2115/index.md)","id":"CVE-2020-2115","markdown":"https://insights.sbomify.com/CVE-2020-2115/index.md","name":"CVE-2020-2115","record":{"aliases":["GHSA-xvhf-q744-5xm8"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["data_read","denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins NUnit Plugin","requires_auth":"low_privilege","summary":"An attacker can exploit XML external entity vulnerabilities in the Jenkins NUnit Plugin to read sensitive files or cause denial of service.","user_interaction":"not_required","vuln_class":"xxe"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"jenkins","cpe":[{"product":"nunit","vendor":"jenkins"}],"cvss":{"score":8.8,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-611","name":"Improper Restriction of XML External Entity Reference"}],"description":"Jenkins NUnit Plugin 0.25 and earlier does not configure the XML parser to prevent XML external entity (XXE) attacks.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"XXE vulnerability in NUnit Plugin","id":"CVE-2020-2115","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"xxe","year":"2020"},"n_packages":2,"n_references":2,"next":{"headline":"CSRF vulnerability in Pipeline GitHub Notify Step Plugin allows capturing credentials","id":"CVE-2020-2116"},"packages":[{"ecosystem":"Maven","fixed":["0.26"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:nunit","purl":null,"source":"GHSA-xvhf-q744-5xm8"},{"ecosystem":"Maven","fixed":["0.26"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:nunit","purl":"pkg:maven/org.jenkins-ci.plugins/nunit","source":"GHSA-xvhf-q744-5xm8"}],"prev":{"headline":"Jenkins S3 Publisher Plugin transmits credentials in plain text during configuration","id":"CVE-2020-2114"},"products":["Jenkins NUnit Plugin"],"published":"2020-02-12","related":[{"cvss_score":5.3,"headline":"Jenkins NUnit Plugin vulnerable to Protection Mechanism Failure","id":"CVE-2022-43414","kev_date_added":null,"published":"2022-10-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["Jenkins project"]},"summary":"An attacker can exploit XML external entity vulnerabilities in the Jenkins NUnit Plugin to read sensitive files or cause denial of service.","url":"https://insights.sbomify.com/CVE-2020-2115/"}