{"answers":{"affected":"2 open source packages ship an affected version, including org.jenkins-ci.plugins:pipeline-githubnotify-step. It affects 1 product.","exploited":"There is no known exploitation of CVE-2020-2116 in the wild and no public exploit code.","fix":"Upgrade org.jenkins-ci.plugins:pipeline-githubnotify-step to 1.0.5 or later.","what":"CVE-2020-2116 is a high-severity vulnerability in Jenkins Pipeline GitHub Notify Step Plugin, published on 12 Feb 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2020-2116 and fix it if it is affected.\n\nWhat it is: CVE-2020-2116 is a high-severity vulnerability in Jenkins Pipeline GitHub Notify Step Plugin, published on 12 Feb 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2020-2116 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.jenkins-ci.plugins:pipeline-githubnotify-step (Maven): affected all versions; fixed in 1.0.5\n- org.jenkins-ci.plugins:pipeline-githubnotify-step (Maven): affected all versions; fixed in 1.0.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-2116/ (Markdown: https://insights.sbomify.com/CVE-2020-2116/index.md)","id":"CVE-2020-2116","markdown":"https://insights.sbomify.com/CVE-2020-2116/index.md","name":"CVE-2020-2116","record":{"aliases":["GHSA-qhxf-m7jm-jc57"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins CI plugin","requires_auth":"none","summary":"Attackers can exploit CSRF to force Jenkins to connect to malicious URLs, potentially capturing stored credentials via attacker-specified IDs.","user_interaction":"required","vuln_class":"csrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"jenkins","cpe":[{"product":"pipeline_github_notify_step","vendor":"jenkins"}],"cvss":{"score":8.8,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-352","name":"Cross-Site Request Forgery"}],"description":"A cross-site request forgery vulnerability in Jenkins Pipeline GitHub Notify Step Plugin 1.0.4 and earlier allows attackers to connect to an attacker-specified URL using attacker-specified credentials IDs obtained through another method, capturing credentials stored in Jenkins.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"CSRF vulnerability in Pipeline GitHub Notify Step Plugin allows capturing credentials","id":"CVE-2020-2116","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"csrf","year":"2020"},"n_packages":2,"n_references":2,"next":{"headline":"Missing permission checks in Pipeline GitHub Notify Step Plugin allows capturing credentials","id":"CVE-2020-2117"},"packages":[{"ecosystem":"Maven","fixed":["1.0.5"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:pipeline-githubnotify-step","purl":null,"source":"GHSA-qhxf-m7jm-jc57"},{"ecosystem":"Maven","fixed":["1.0.5"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:pipeline-githubnotify-step","purl":"pkg:maven/org.jenkins-ci.plugins/pipeline-githubnotify-step","source":"GHSA-qhxf-m7jm-jc57"}],"prev":{"headline":"XXE vulnerability in NUnit Plugin","id":"CVE-2020-2115"},"products":["Jenkins Pipeline GitHub Notify Step Plugin"],"published":"2020-02-12","related":[{"cvss_score":4.3,"headline":"Missing permission checks in Pipeline GitHub Notify Step Plugin allows capturing credentials","id":"CVE-2020-2117","kev_date_added":null,"published":"2020-02-12"},{"cvss_score":4.3,"headline":"Users with Overall/Read access can enumerate credential IDs in Pipeline GitHub Notify Step Plugin","id":"CVE-2020-2118","kev_date_added":null,"published":"2020-02-12"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["Jenkins project"]},"summary":"Attackers can exploit CSRF to force Jenkins to connect to malicious URLs, potentially capturing stored credentials via attacker-specified IDs.","url":"https://insights.sbomify.com/CVE-2020-2116/"}