# CVE-2020-2120: XXE vulnerability in FitNesse Plugin

> An attacker can exploit XML external entity vulnerabilities in the Jenkins FitNesse Plugin to read sensitive files or cause denial of service.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Feb 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-c3cg-mv5w-cvw8

## What is CVE-2020-2120?

CVE-2020-2120 is a high-severity vulnerability in Jenkins FitNesse Plugin, published on 12 Feb 2020. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Jenkins FitNesse Plugin 1.30 and earlier does not configure the XML parser to prevent XML external entity (XXE) attacks.

Weakness: CWE-611 (Improper Restriction of XML External Entity Reference)

## Which versions are affected by CVE-2020-2120?

2 open source packages ship an affected version, including org.jenkins-ci.plugins:fitnesse. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:fitnesse` | Maven | All versions | 1.31 |
| `org.jenkins-ci.plugins:fitnesse` | Maven | All versions | 1.31 |

Products: Jenkins Fitnesse.

## How do I fix CVE-2020-2120?

Upgrade org.jenkins-ci.plugins:fitnesse to 1.31 or later.

## Is CVE-2020-2120 being exploited?

There is no known exploitation of CVE-2020-2120 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins FitNesse Plugin

- [CVE-2020-2175](https://insights.sbomify.com/CVE-2020-2175/): Stored XSS vulnerability in Jenkins FitNesse Plugin (medium 5.4)
- [CVE-2026-57302](https://insights.sbomify.com/CVE-2026-57302/): Jenkins FitNesse Plugin stores passwords unencrypted (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-2120 and fix it if it is affected.

What it is: CVE-2020-2120 is a high-severity vulnerability in Jenkins FitNesse Plugin, published on 12 Feb 2020. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-2120 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:fitnesse (Maven): affected all versions; fixed in 1.31
- org.jenkins-ci.plugins:fitnesse (Maven): affected all versions; fixed in 1.31

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-2120/ (Markdown: https://insights.sbomify.com/CVE-2020-2120/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-2120
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-2120
- OSV: https://osv.dev/vulnerability/CVE-2020-2120

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-2120/
Summaries are generated and may contain mistakes; the official description above is the record.
