{"answers":{"affected":"2 open source packages ship an affected version, including org.jenkins-ci.plugins:google-kubernetes-engine. It affects 1 product.","exploited":"There is no known exploitation of CVE-2020-2121 in the wild and no public exploit code.","fix":"Upgrade org.jenkins-ci.plugins:google-kubernetes-engine to 0.8.1 or later.","what":"CVE-2020-2121 is a high-severity unsafe deserialization vulnerability in Jenkins Google Kubernetes Engine Plugin, published on 12 Feb 2020. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2020-2121 and fix it if it is affected.\n\nWhat it is: CVE-2020-2121 is a high-severity unsafe deserialization vulnerability in Jenkins Google Kubernetes Engine Plugin, published on 12 Feb 2020. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2020-2121 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.jenkins-ci.plugins:google-kubernetes-engine (Maven): affected all versions; fixed in 0.8.1\n- org.jenkins-ci.plugins:google-kubernetes-engine (Maven): affected all versions; fixed in 0.8.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-2121/ (Markdown: https://insights.sbomify.com/CVE-2020-2121/index.md)","id":"CVE-2020-2121","markdown":"https://insights.sbomify.com/CVE-2020-2121/index.md","name":"CVE-2020-2121","record":{"aliases":["GHSA-wf76-qgqq-gcfj"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins GKE Plugin","requires_auth":"low_privilege","summary":"Remote attackers can execute arbitrary code via unsafe YAML deserialization in the Jenkins Google Kubernetes Engine Plugin.","user_interaction":"not_required","vuln_class":"deserialization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"jenkins","cpe":[{"product":"google_kubernetes_engine","vendor":"jenkins"}],"cvss":{"score":8.8,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[],"description":"Jenkins Google Kubernetes Engine Plugin 0.8.0 and earlier does not configure its YAML parser to prevent the instantiation of arbitrary types, resulting in a remote code execution vulnerability.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"RCE vulnerability in Google Kubernetes Engine Plugin","id":"CVE-2020-2121","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"deserialization","year":"2020"},"n_packages":2,"n_references":2,"next":{"headline":"Stored XSS vulnerability in Jenkins brakeman Plugin","id":"CVE-2020-2122"},"packages":[{"ecosystem":"Maven","fixed":["0.8.1"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:google-kubernetes-engine","purl":null,"source":"GHSA-wf76-qgqq-gcfj"},{"ecosystem":"Maven","fixed":["0.8.1"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:google-kubernetes-engine","purl":"pkg:maven/org.jenkins-ci.plugins/google-kubernetes-engine","source":"GHSA-wf76-qgqq-gcfj"}],"prev":{"headline":"XXE vulnerability in FitNesse Plugin","id":"CVE-2020-2120"},"products":["Jenkins Google Kubernetes Engine Plugin"],"published":"2020-02-12","related":[{"cvss_score":4.3,"headline":"Missing permission checks in Google Kubernetes Engine Jenkins Plugin","id":"CVE-2019-10445","kev_date_added":null,"published":"2019-10-16"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["Jenkins project"]},"summary":"Remote attackers can execute arbitrary code via unsafe YAML deserialization in the Jenkins Google Kubernetes Engine Plugin.","url":"https://insights.sbomify.com/CVE-2020-2121/"}