{"answers":{"affected":"2 open source packages ship an affected version, including org.jenkins-ci.plugins:radargun. It affects 1 product.","exploited":"There is no known exploitation of CVE-2020-2123 in the wild and no public exploit code.","fix":"Upgrade org.jenkins-ci.plugins:radargun to 1.8 or later.","what":"CVE-2020-2123 is a high-severity unsafe deserialization vulnerability in Jenkins RadarGun Plugin, published on 12 Feb 2020. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2020-2123 and fix it if it is affected.\n\nWhat it is: CVE-2020-2123 is a high-severity unsafe deserialization vulnerability in Jenkins RadarGun Plugin, published on 12 Feb 2020. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2020-2123 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.jenkins-ci.plugins:radargun (Maven): affected all versions; fixed in 1.8\n- org.jenkins-ci.plugins:radargun (Maven): affected all versions; fixed in 1.8\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-2123/ (Markdown: https://insights.sbomify.com/CVE-2020-2123/index.md)","id":"CVE-2020-2123","markdown":"https://insights.sbomify.com/CVE-2020-2123/index.md","name":"CVE-2020-2123","record":{"aliases":["GHSA-723p-9rcj-xv8j"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins RadarGun Plugin","requires_auth":"low_privilege","summary":"Remote attackers can execute arbitrary code on Jenkins servers via unsafe YAML deserialization in the RadarGun Plugin.","user_interaction":"not_required","vuln_class":"deserialization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"jenkins","cpe":[{"product":"radargun","vendor":"jenkins"}],"cvss":{"score":8.8,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-502","name":"Deserialization of Untrusted Data"}],"description":"Jenkins RadarGun Plugin 1.7 and earlier does not configure its YAML parser to prevent the instantiation of arbitrary types, resulting in a remote code execution vulnerability.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"RCE vulnerability in RadarGun Plugin","id":"CVE-2020-2123","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"deserialization","year":"2020"},"n_packages":2,"n_references":2,"next":{"headline":"Password stored in plain text by Dynamic Extended Choice Parameter Plugin","id":"CVE-2020-2124"},"packages":[{"ecosystem":"Maven","fixed":["1.8"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:radargun","purl":null,"source":"GHSA-723p-9rcj-xv8j"},{"ecosystem":"Maven","fixed":["1.8"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:radargun","purl":"pkg:maven/org.jenkins-ci.plugins/radargun","source":"GHSA-723p-9rcj-xv8j"}],"prev":{"headline":"Stored XSS vulnerability in Jenkins brakeman Plugin","id":"CVE-2020-2122"},"products":["Jenkins RadarGun Plugin"],"published":"2020-02-12","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["Jenkins project"]},"summary":"Remote attackers can execute arbitrary code on Jenkins servers via unsafe YAML deserialization in the RadarGun Plugin.","url":"https://insights.sbomify.com/CVE-2020-2123/"}