{"answers":{"affected":"2 open source packages ship an affected version, including sheng/yiicms. It affects 1 product.","exploited":"There is no known exploitation of CVE-2020-21246 in the wild and no public exploit code.","fix":"Upgrade sheng/yiicms to 1.2.1 or later.","what":"CVE-2020-21246 is a medium-severity cross-site scripting vulnerability in n/a, published on 20 Jun 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2020-21246 and fix it if it is affected.\n\nWhat it is: CVE-2020-21246 is a medium-severity cross-site scripting vulnerability in n/a, published on 20 Jun 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2020-21246 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- sheng/yiicms (Packagist): affected all versions; fixed in 1.2.1\n- sheng/yiicms (Packagist): affected all versions; fixed in 1.2.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-21246/ (Markdown: https://insights.sbomify.com/CVE-2020-21246/index.md)","id":"CVE-2020-21246","markdown":"https://insights.sbomify.com/CVE-2020-21246/index.md","name":"CVE-2020-21246","record":{"aliases":["GHSA-gqr4-cvf4-3957"],"analysis":{"component_type":"web_application","fix_type":"no_fix_stated","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"YiiCMS","requires_auth":"low_privilege","summary":"A remote attacker can execute arbitrary code via a Cross-Site Scripting vulnerability in the news function of YiiCMS.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"yiicms","vendor":"yiicms_project"}],"cvss":{"score":5.4,"severity":"medium","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Cross Site Scripting vulnerability in YiiCMS v.1.0 allows a remote attacker to execute arbitrary code via the news function.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"YiiCMS Cross Site Scripting vulnerability","id":"CVE-2020-21246","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2020"},"n_packages":2,"n_references":1,"next":{"headline":"File upload in n/a","id":"CVE-2020-21250"},"packages":[{"ecosystem":"Packagist","fixed":["1.2.1"],"introduced":["0"],"last_affected":[],"package":"sheng/yiicms","purl":null,"source":"GHSA-gqr4-cvf4-3957"},{"ecosystem":"Packagist","fixed":["1.2.1"],"introduced":["0"],"last_affected":[],"package":"sheng/yiicms","purl":"pkg:composer/sheng/yiicms","source":"GHSA-gqr4-cvf4-3957"}],"prev":{"headline":"Path traversal in n/a","id":"CVE-2020-21244"},"products":["n/a"],"published":"2023-06-20","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-12-10","vendors":["n/a"]},"summary":"A remote attacker can execute arbitrary code via a Cross-Site Scripting vulnerability in the news function of YiiCMS.","url":"https://insights.sbomify.com/CVE-2020-21246/"}