# CVE-2020-21246: YiiCMS Cross Site Scripting vulnerability

> A remote attacker can execute arbitrary code via a Cross-Site Scripting vulnerability in the news function of YiiCMS.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 20 Jun 2023
- **Updated:** 10 Dec 2024
- **Also known as:** GHSA-gqr4-cvf4-3957

## What is CVE-2020-21246?

CVE-2020-21246 is a medium-severity cross-site scripting vulnerability in n/a, published on 20 Jun 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Cross Site Scripting vulnerability in YiiCMS v.1.0 allows a remote attacker to execute arbitrary code via the news function.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2020-21246?

2 open source packages ship an affected version, including sheng/yiicms. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `sheng/yiicms` | Packagist | All versions | 1.2.1 |
| `sheng/yiicms` | Packagist | All versions | 1.2.1 |

Products: Yiicms Project Yiicms.

## How do I fix CVE-2020-21246?

Upgrade sheng/yiicms to 1.2.1 or later.

## Is CVE-2020-21246 being exploited?

There is no known exploitation of CVE-2020-21246 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-21246 and fix it if it is affected.

What it is: CVE-2020-21246 is a medium-severity cross-site scripting vulnerability in n/a, published on 20 Jun 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2020-21246 in the wild and no public exploit code.

Affected packages and fixed versions:
- sheng/yiicms (Packagist): affected all versions; fixed in 1.2.1
- sheng/yiicms (Packagist): affected all versions; fixed in 1.2.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-21246/ (Markdown: https://insights.sbomify.com/CVE-2020-21246/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-21246
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-21246
- OSV: https://osv.dev/vulnerability/CVE-2020-21246

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-21246/
Summaries are generated and may contain mistakes; the official description above is the record.
