# CVE-2020-2137: Stored XSS vulnerability in Jenkins Timestamper Plugin

> Stored XSS in Jenkins Timestamper Plugin allows attackers with admin permissions to execute arbitrary scripts in victim browsers.

- **Severity:** Medium 4.8 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 9 Mar 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-6xxf-rwv4-mrjm

## What is CVE-2020-2137?

CVE-2020-2137 is a medium-severity cross-site scripting vulnerability in Jenkins Timestamper Plugin, published on 9 Mar 2020. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

Jenkins Timestamper Plugin 1.11.1 and earlier does not sanitize HTML formatting of its output, resulting in a stored XSS vulnerability exploitable by attackers with Overall/Administer permission.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2020-2137?

2 open source packages ship an affected version, including org.jenkins-ci.plugins:timestamper. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:timestamper` | Maven | All versions | 1.11.2 |
| `org.jenkins-ci.plugins:timestamper` | Maven | All versions | 1.11.2 |

Products: Jenkins Timestamper.

## How do I fix CVE-2020-2137?

Upgrade org.jenkins-ci.plugins:timestamper to 1.11.2 or later.

## Is CVE-2020-2137 being exploited?

There is no known exploitation of CVE-2020-2137 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-2137 and fix it if it is affected.

What it is: CVE-2020-2137 is a medium-severity cross-site scripting vulnerability in Jenkins Timestamper Plugin, published on 9 Mar 2020. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2020-2137 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:timestamper (Maven): affected all versions; fixed in 1.11.2
- org.jenkins-ci.plugins:timestamper (Maven): affected all versions; fixed in 1.11.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-2137/ (Markdown: https://insights.sbomify.com/CVE-2020-2137/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-2137
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-2137
- OSV: https://osv.dev/vulnerability/CVE-2020-2137

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-2137/
Summaries are generated and may contain mistakes; the official description above is the record.
