{"answers":{"affected":"2 open source packages ship an affected version, including org.jenkins-ci.plugins:cobertura. It affects 1 product.","exploited":"There is no known exploitation of CVE-2020-2138 in the wild and no public exploit code.","fix":"Upgrade org.jenkins-ci.plugins:cobertura to 1.16 or later.","what":"CVE-2020-2138 is a high-severity vulnerability in Jenkins Cobertura Plugin, published on 9 Mar 2020. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2020-2138 and fix it if it is affected.\n\nWhat it is: CVE-2020-2138 is a high-severity vulnerability in Jenkins Cobertura Plugin, published on 9 Mar 2020. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2020-2138 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.jenkins-ci.plugins:cobertura (Maven): affected all versions; fixed in 1.16\n- org.jenkins-ci.plugins:cobertura (Maven): affected all versions; fixed in 1.16\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-2138/ (Markdown: https://insights.sbomify.com/CVE-2020-2138/index.md)","id":"CVE-2020-2138","markdown":"https://insights.sbomify.com/CVE-2020-2138/index.md","name":"CVE-2020-2138","record":{"aliases":["GHSA-vpfj-5gg5-fvfm"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["data_read","denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins Cobertura Plugin","requires_auth":"low_privilege","summary":"An attacker can exploit XML external entity vulnerabilities in the Jenkins Cobertura Plugin to read sensitive files or cause denial of service.","user_interaction":"not_required","vuln_class":"xxe"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"jenkins","cpe":[{"product":"cobertura","vendor":"jenkins"}],"cvss":{"score":7.1,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-611","name":"Improper Restriction of XML External Entity Reference"}],"description":"Jenkins Cobertura Plugin 1.15 and earlier does not configure its XML parser to prevent XML external entity (XXE) attacks.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"XXE vulnerability in Jenkins Cobertura Plugin","id":"CVE-2020-2138","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"xxe","year":"2020"},"n_packages":2,"n_references":2,"next":{"headline":"Arbitrary file write vulnerability in Jenkins Cobertura Plugin","id":"CVE-2020-2139"},"packages":[{"ecosystem":"Maven","fixed":["1.16"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:cobertura","purl":null,"source":"GHSA-vpfj-5gg5-fvfm"},{"ecosystem":"Maven","fixed":["1.16"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:cobertura","purl":"pkg:maven/org.jenkins-ci.plugins/cobertura","source":"GHSA-vpfj-5gg5-fvfm"}],"prev":{"headline":"Stored XSS vulnerability in Jenkins Timestamper Plugin","id":"CVE-2020-2137"},"products":["Jenkins Cobertura Plugin"],"published":"2020-03-09","related":[{"cvss_score":6.5,"headline":"Arbitrary file write vulnerability in Jenkins Cobertura Plugin","id":"CVE-2020-2139","kev_date_added":null,"published":"2020-03-09"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["Jenkins project"]},"summary":"An attacker can exploit XML external entity vulnerabilities in the Jenkins Cobertura Plugin to read sensitive files or cause denial of service.","url":"https://insights.sbomify.com/CVE-2020-2138/"}