# CVE-2020-2142: Missing permission checks in Jenkins P4 Plugin

> Attackers with read access can trigger builds due to missing permission checks in the Jenkins P4 Plugin.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Mar 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-f9v6-p7hp-c3qx

## What is CVE-2020-2142?

CVE-2020-2142 is a medium-severity missing authorization vulnerability in Jenkins P4 Plugin, published on 9 Mar 2020. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A missing permission check in Jenkins P4 Plugin 1.10.10 and earlier allows attackers with Overall/Read permission to trigger builds.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2020-2142?

2 open source packages ship an affected version, including org.jenkins-ci.plugins:p4. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:p4` | Maven | All versions | 1.10.11 |
| `org.jenkins-ci.plugins:p4` | Maven | All versions | 1.10.11 |

Products: Jenkins P4.

## How do I fix CVE-2020-2142?

Upgrade org.jenkins-ci.plugins:p4 to 1.10.11 or later.

## Is CVE-2020-2142 being exploited?

There is no known exploitation of CVE-2020-2142 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins P4 Plugin

- [CVE-2021-21655](https://insights.sbomify.com/CVE-2021-21655/): Cross-Site Request Forgery in Jenkins P4 Plugin (high 7.1)
- [CVE-2021-21654](https://insights.sbomify.com/CVE-2021-21654/): Missing Authorization in Jenkins P4 plugin (medium 4.3)
- [CVE-2020-2141](https://insights.sbomify.com/CVE-2020-2141/): CSRF vulnerability in Jenkins P4 Plugin (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-2142 and fix it if it is affected.

What it is: CVE-2020-2142 is a medium-severity missing authorization vulnerability in Jenkins P4 Plugin, published on 9 Mar 2020. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-2142 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:p4 (Maven): affected all versions; fixed in 1.10.11
- org.jenkins-ci.plugins:p4 (Maven): affected all versions; fixed in 1.10.11

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-2142/ (Markdown: https://insights.sbomify.com/CVE-2020-2142/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-2142
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-2142
- OSV: https://osv.dev/vulnerability/CVE-2020-2142

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-2142/
Summaries are generated and may contain mistakes; the official description above is the record.
