# CVE-2020-21469: Denial of service in n/a

> Attackers with high privileges can cause denial of service by repeatedly sending SIGHUP signals to PostgreSQL.

- **Severity:** Medium 4.4 (`CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Aug 2023
- **Updated:** 4 Aug 2024
- **Also known as:** BIT-postgresql-2020-21469, ECHO-aad0-5c96-9b71, GHSA-w8hm-59h4-7ff2, UBUNTU-CVE-2020-21469

## What is CVE-2020-21469?

CVE-2020-21469 is a medium-severity denial of service vulnerability in Postgresql Postgresql, published on 22 Aug 2023. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

An issue was discovered in PostgreSQL 12.2 allows attackers to cause a denial of service via repeatedly sending SIGHUP signals. NOTE: this is disputed by the vendor because untrusted users cannot send SIGHUP signals; they can only be sent by a PostgreSQL superuser, a user with pg_reload_conf access, or a user with sufficient privileges at the OS level (the postgres account or the root account).

Weakness: CWE-120 (Buffer Copy without Checking Size of Input)

## Which versions are affected by CVE-2020-21469?

1 open source package ship an affected version, including postgresql. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `postgresql` | Bitnami | From 12.2.0 | 12.2.1 |

Products: Postgresql Postgresql.

## How do I fix CVE-2020-21469?

Upgrade postgresql to 12.2.1 or later.

## Is CVE-2020-21469 being exploited?

There is no known exploitation of CVE-2020-21469 in the wild and no public exploit code.

## Other vulnerabilities in Postgresql Postgresql

- [CVE-2013-1902](https://insights.sbomify.com/CVE-2013-1902/): Information disclosure in n/a (critical 10.0)
- [CVE-2013-1903](https://insights.sbomify.com/CVE-2013-1903/): Information disclosure in n/a (critical 10.0)
- [CVE-2007-3279](https://insights.sbomify.com/CVE-2007-3279/): Privilege escalation in n/a (critical 10.0)
- [CVE-2002-1399](https://insights.sbomify.com/CVE-2002-1399/): Integer overflow in n/a (critical 10.0)
- [CVE-2016-3065](https://insights.sbomify.com/CVE-2016-3065/): Information disclosure in n/a (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-21469 and fix it if it is affected.

What it is: CVE-2020-21469 is a medium-severity denial of service vulnerability in Postgresql Postgresql, published on 22 Aug 2023. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-21469 in the wild and no public exploit code.

Affected packages and fixed versions:
- postgresql (Bitnami): affected from 12.2.0; fixed in 12.2.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-21469/ (Markdown: https://insights.sbomify.com/CVE-2020-21469/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-21469
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-21469
- OSV: https://osv.dev/vulnerability/CVE-2020-21469

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-21469/
Summaries are generated and may contain mistakes; the official description above is the record.
