{"answers":{"affected":"3 open source packages ship an affected version, including fluentd-ui and fluentd. It affects 2 products.","exploited":"There is no known exploitation of CVE-2020-21514 in the wild and no public exploit code.","fix":"Apply the vendor's patch.","what":"CVE-2020-21514 is a high-severity vulnerability in n/a, published on 4 Apr 2023. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2020-21514 and fix it if it is affected.\n\nWhat it is: CVE-2020-21514 is a high-severity vulnerability in n/a, published on 4 Apr 2023. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2020-21514 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- fluentd-ui (RubyGems): affected all versions up to 1.2.2; no fix listed\n- fluentd-ui (RubyGems): affected all versions up to 1.2.2; no fix listed\n- fluentd (Bitnami): affected from 1.8.0; fixed in 1.8.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-21514/ (Markdown: https://insights.sbomify.com/CVE-2020-21514/index.md)","id":"CVE-2020-21514","markdown":"https://insights.sbomify.com/CVE-2020-21514/index.md","name":"CVE-2020-21514","record":{"aliases":["BIT-fluentd-2020-21514","GHSA-wrxf-x8rm-6ggg"],"analysis":{"component_type":"server_software","fix_type":"patch","impacts":["code_execution","privilege_escalation"],"network_reachable":"yes","non_default_config":false,"product_category":"Fluentd UI","requires_auth":"low_privilege","summary":"Attackers can gain escalated privileges and execute arbitrary code in Fluent-ui due to a default password.","user_interaction":"not_required","vuln_class":"hardcoded_credentials"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"fluentd","vendor":"fluentd"},{"product":"fluentd-ui","vendor":"fluentd"}],"cvss":{"score":8.8,"severity":"high","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-276","name":"Incorrect Default Permissions"}],"description":"An issue was discovered in Fluent-ui v.1.2.2 allows attackers to gain escalated privileges and execute arbitrary code due to a default password.","ecosystems":["Bitnami","RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Fluent Fluentd and Fluent-ui use default password","id":"CVE-2020-21514","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"hardcoded_credentials","year":"2020"},"n_packages":3,"n_references":2,"next":{"headline":"FeehiCMS has an arbitrary file upload vulnerability","id":"CVE-2020-21516"},"packages":[{"ecosystem":"Bitnami","fixed":["1.8.1"],"introduced":["1.8.0"],"last_affected":[],"package":"fluentd","purl":"pkg:bitnami/fluentd","source":"BIT-fluentd-2020-21514"},{"ecosystem":"RubyGems","fixed":[],"introduced":["0"],"last_affected":["1.2.2"],"package":"fluentd-ui","purl":null,"source":"GHSA-wrxf-x8rm-6ggg"},{"ecosystem":"RubyGems","fixed":[],"introduced":["0"],"last_affected":["1.2.2"],"package":"fluentd-ui","purl":"pkg:gem/fluentd-ui","source":"GHSA-wrxf-x8rm-6ggg"}],"prev":{"headline":"Cross-site scripting in n/a","id":"CVE-2020-21506"},"products":["n/a"],"published":"2023-04-04","related":[{"cvss_score":9.8,"headline":"Fluentd: Remote Code Execution (RCE) via Arbitrary File Write in `${tag}` Placeholder","id":"CVE-2026-44024","kev_date_added":null,"published":"2026-07-08"},{"cvss_score":9.8,"headline":"Fluentd Escape Sequence Injection Vulnerability","id":"CVE-2017-10906","kev_date_added":null,"published":"2017-12-08"},{"cvss_score":7.5,"headline":"Fluentd: Exposure of Sensitive Information via Monitor Agent API","id":"CVE-2026-44025","kev_date_added":null,"published":"2026-07-08"},{"cvss_score":7.5,"headline":"Fluentd: Denial of Service (DoS) via Gzip Decompression Bomb in `in_http` and `in_forward`","id":"CVE-2026-44160","kev_date_added":null,"published":"2026-07-08"},{"cvss_score":7.2,"headline":"Fluentd: Server-Side Request Forgery (SSRF) via Placeholder Expansion in `out_http`","id":"CVE-2026-44161","kev_date_added":null,"published":"2026-07-08"},{"cvss_score":5.9,"headline":"ReDoS vulnerability in parser_apache2","id":"CVE-2021-41186","kev_date_added":null,"published":"2021-10-29"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-06-09","vendors":["n/a"]},"summary":"Attackers can gain escalated privileges and execute arbitrary code in Fluent-ui due to a default password.","url":"https://insights.sbomify.com/CVE-2020-21514/"}