# CVE-2020-21514: Fluent Fluentd and Fluent-ui use default password

> Attackers can gain escalated privileges and execute arbitrary code in Fluent-ui due to a default password.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Apr 2023
- **Updated:** 9 Jun 2025
- **Also known as:** BIT-fluentd-2020-21514, GHSA-wrxf-x8rm-6ggg

## What is CVE-2020-21514?

CVE-2020-21514 is a high-severity vulnerability in n/a, published on 4 Apr 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

An issue was discovered in Fluent-ui v.1.2.2 allows attackers to gain escalated privileges and execute arbitrary code due to a default password.

Weakness: CWE-276 (Incorrect Default Permissions)

## Which versions are affected by CVE-2020-21514?

3 open source packages ship an affected version, including fluentd-ui and fluentd. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `fluentd-ui` | RubyGems | All versions to 1.2.2 | None |
| `fluentd-ui` | RubyGems | All versions to 1.2.2 | None |
| `fluentd` | Bitnami | From 1.8.0 | 1.8.1 |

Products: Fluentd Fluentd, Fluentd Fluentd-Ui.

## How do I fix CVE-2020-21514?

Apply the vendor's patch.

## Is CVE-2020-21514 being exploited?

There is no known exploitation of CVE-2020-21514 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2026-44024](https://insights.sbomify.com/CVE-2026-44024/): Fluentd: Remote Code Execution (RCE) via Arbitrary File Write in `${tag}` Placeholder (critical 9.8)
- [CVE-2017-10906](https://insights.sbomify.com/CVE-2017-10906/): Fluentd Escape Sequence Injection Vulnerability (critical 9.8)
- [CVE-2026-44025](https://insights.sbomify.com/CVE-2026-44025/): Fluentd: Exposure of Sensitive Information via Monitor Agent API (high 7.5)
- [CVE-2026-44160](https://insights.sbomify.com/CVE-2026-44160/): Fluentd: Denial of Service (DoS) via Gzip Decompression Bomb in `in_http` and `in_forward` (high 7.5)
- [CVE-2026-44161](https://insights.sbomify.com/CVE-2026-44161/): Fluentd: Server-Side Request Forgery (SSRF) via Placeholder Expansion in `out_http` (high 7.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-21514 and fix it if it is affected.

What it is: CVE-2020-21514 is a high-severity vulnerability in n/a, published on 4 Apr 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-21514 in the wild and no public exploit code.

Affected packages and fixed versions:
- fluentd-ui (RubyGems): affected all versions up to 1.2.2; no fix listed
- fluentd-ui (RubyGems): affected all versions up to 1.2.2; no fix listed
- fluentd (Bitnami): affected from 1.8.0; fixed in 1.8.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-21514/ (Markdown: https://insights.sbomify.com/CVE-2020-21514/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-21514
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-21514
- OSV: https://osv.dev/vulnerability/CVE-2020-21514

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-21514/
Summaries are generated and may contain mistakes; the official description above is the record.
