# CVE-2020-2153: Credentials transmitted in plain text by Backlog Plugin

> Attackers can view Jenkins Backlog Plugin credentials in plain text via job configuration forms, leading to potential credential exposure.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Mar 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-p68c-xg89-2g5r

## What is CVE-2020-2153?

CVE-2020-2153 is a medium-severity vulnerability in Jenkins Backlog Plugin, published on 9 Mar 2020. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Jenkins Backlog Plugin 2.4 and earlier transmits configured credentials in plain text as part of job configuration forms, potentially resulting in their exposure.

Weakness: CWE-319 (Cleartext Transmission of Sensitive Information)

## Which versions are affected by CVE-2020-2153?

2 open source packages ship an affected version, including org.jenkins-ci.plugins:backlog. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:backlog` | Maven | All versions | 2.5 |
| `org.jenkins-ci.plugins:backlog` | Maven | All versions | 2.5 |

Products: Jenkins Backlog.

## How do I fix CVE-2020-2153?

Upgrade org.jenkins-ci.plugins:backlog to 2.5 or later.

## Is CVE-2020-2153 being exploited?

There is no known exploitation of CVE-2020-2153 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-2153 and fix it if it is affected.

What it is: CVE-2020-2153 is a medium-severity vulnerability in Jenkins Backlog Plugin, published on 9 Mar 2020. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-2153 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:backlog (Maven): affected all versions; fixed in 2.5
- org.jenkins-ci.plugins:backlog (Maven): affected all versions; fixed in 2.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-2153/ (Markdown: https://insights.sbomify.com/CVE-2020-2153/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-2153
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-2153
- OSV: https://osv.dev/vulnerability/CVE-2020-2153

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-2153/
Summaries are generated and may contain mistakes; the official description above is the record.
